Brave Browser Slow To Access A Webpage After Initial Startup

Description of the issue:
How can this issue be reproduced?

  1. Open browser
  2. The moment browser is open navigate to a web address immediately.
  3. It will take 10-15 seconds to even start navigating to the webpage. Afterwards, if you try to navigate to a different webpage the browser is fine.

Expected result:
It should load the first webpage upon opening the browser normally.

Brave Version( check About Brave):

Additional Information:

When I open Brave and immediately navigate to a page it takes 10-15 seconds before it even starts to navigate to the webpage. Afterwards, it’ll work navigate to the webpage and work fine for any subsequent webpages. This only occurs if Brave isn’t already running and I’ve just opened it. If I’ve opened it, not done anything for a few moments, and then navigate to a webpage it works fine.
It seems like it’s still doing something in the background even though it looks like the browser has completely loaded. I thought maybe an extension might be causing some delays, but I turned all of them off and I still have the same result. This is something that started occuring a couple of weeks or so ago.

Hello @dragonandante

Thanks for bringing this to our attention and I’m sorry to hear you are going through this. If you disable your shields while browsing is open the issue persist?

Have a great day!

Hello @Alice2095 ,
I didn’t see a straight forward way to turn off shields so I just set shield settings to the following:

However, I still get the same results. Do note that no extensions are currently running in this case.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.