Error 0xc0000409 on install of new version

windows
bug

#1

Description of the issue:
I cannot install the new version with the new installer.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Run BraveBrowserSetup.exe
  2. Wait for download
  3. error 0xc0000409

Actual Result (gifs and screenshots are welcome!):
brave%20install%20error
Expected result:
I expected to see the installer on the next step.

Reproduces how often:
Every time. I’ve downloaded the setup multiple times on different days.

Brave Version(about:brave):
Not sure, the download page doesn’t show what version it should be. It’s from “latest” on 2018-12-30

Reproducible on current live release (yes/no):
yes

Additional Information:
I’ve been using the old branch from early on. The old installer didn’t have this problem.


#2

Thanks for reporting @HowBrave.
Can yoi try download the standalone installer from this link? https://github.com/brave/brave-browser/releases/tag/v0.58.18

cc @Mattches
Thanks
:slightly_smiling_face:


#3

Thanks @eljuno but I get the same error when I run the standalone installer.


#4

@HowBrave,
Thanks for reaching out! We’re aware of the installer error and are already working on a fix for the issue. We appreciate your patience.

Just to check, do you have any anti-virus software installed on your machine?


#5

Yes, I run anti-virus with personal firewall. I know how to make exceptions to allow programs to run through all the shields.


#6

Well that’s great, but that error points to “unknown software” conflicts. Your AV software (or a plugin for it) may be blocking the installer from completing. What AV are you using?


#7

You know, the kind that doesn’t conflict with any other web browser installation on the planet, including your previous version. I apologize for being vague but I think a better question is “What is your installer doing that conflicts with security products in some novel way?”


#8

Well @HowBrave,
A simple search for this type of report here on Community would have revealed several instances of Brave being flagged as malicious by different AV software. The Tor files/executables packaged with Brave for Private Window w/Tor functionality that seem to trigger the AV to flag Brave.

In fact, I’ve just pinned a topic, globally, referencing an issue many users had with Kaspersky AV flagging Brave. The issue (for them) should be resolved by now. We had a similar situation with Malwarebytes that has since been resolved.

If it’s a company we’ve been working with on this, I may be able to point you in the right direction. If its a work in progress, I may have a workaround. If it was supposedly resolved by ‘the company’ on their end and you’re still experiencing the issue, then we need to figure out why that’s the case when it should have been fixed.

So you see, the best question in this case would be exactly what I inquired about - what AV software are you using?

So far, the only information I have is that you

  • Are getting an installation error
  • You’re attempting to install the Brave stable release (probably, right?)
  • You have some mystery Antivirus program installed conflicting with Brave

When you come to request support, please provide the information requested - whether it be by Brave team or the information in the template - with as much relevant detail as possible.


#9

The problem is resolved in the latest version for me. Thank you.


closed #10