Cookie problem with Google calendar

I’m having exactly the same problem as this guy here, but clearing my browser’s cache and cookies didn’t solve it. My Gmail, Hangouts and pretty much everything else is working.

Steps to reproduce:

  1. Open Brave.
  2. Go to, or go to and click on the calendar icon inside the overflow grid at the upper right corner.

I tried everything in the related post, but I can’t solve my issue nor reopen it.

The site is working fine in Chrome.

I’m using Ubuntu 18.04.

Hi @yagodorea. Did you try clearing cache and cookies from all time. By default the clear data setting is set to last one hour. You may want to try clearing for all time and check. Also what is the default shields settings for cookie set to? It should ideally reset if you clear data for all time and restart the browser.

Yes, I tried. I tried even disabling the shields by default, because I can’t find anywhere I can disable them specifically for the calendar website (Google redirects me when I try to access it).

I cant reproduce this issue. It loads the site properly for me on Ubuntu 18.04. Do you have cookies and Javascript allowed in settings?

Well now it’s working, for some magic reason. Thanks for your time, gentlemen.

1 Like

Glad its working. Closing the thread for now. Please open a new thread if you run into this again.

1 Like