Citibank reauthorization for Quicken fails with a blank screen

I ran into an issue today with Brave and a reauthorization process between Quicken and Citibank. In order to download credit card transactions between Citibank and Quicken, Citibank changed things and the ability to download had to be re-authorized. Part of the re-authorization process was that Quicken launched Brave with a unique URL. Brave did attempt to open the page but instead of prompting the user with a logon page, Brave only displayed a blank page. I copied the URL from Brave to Edge and Edge allowed me to logon but since it was coming from a different browser Quicken would not complete the process. The work around was to swap Edge and Brave as my default browser and both Citibank and Quicken were happy campers. After switching Brave back as my default browser, Quicken successfully downloaded my transactions. So I’m not sure why Brave was having an issue but I wanted to post this in case any other Brave user was having the same issue.

@Moondoggy

  • Can you try with Shields off and see if it makes a difference?

  • Perhaps try in Private window?

  • If neither of the above makes a difference, try in a new profile? (Hamburger menu → More Tools → Add New profile. This creates 2nd profile with base settings and no extensions)

Yes, I turned shields off for this site in Brave, came back to Quicken the next day, and still no joy. Blank white screen. The Elements sidebar shows 3-4 scripts.

I have not tried to copy the URL into a private window, but I don’t expect the results to return to Quicken properly, anyway.

I have not done enough with brave for my profile to be much different than default, but I don’t know how that would be returned to quicken, either.

I did not realize that Brave is my default browser, I will try that work-around.

Glad that someone was able to try Saoiray’s suggestions but sorry that they didn’t work. I couldn’t, as I had already reauthorized my Citibank account thru Quicken with my work around. The hard part for Brave support if they are reading this tread is that someone has to have an account with Citibank and download credit card transactions into Quicken in order to diagnose this issue that’s why I suggested doing the temporary default browser swap with Edge instead. It’s a pain to swap default browsers but it gets the job done.

As it turns out, I have not been able to authorize so I have tried both Edge and Google Chrome (as default). Although I am able to successfully log into Citibank’s website with either of those, the message doesn’t get returned to Quicken.

It looks like to me Quicken has an issue here.

keep in mind when an app opens the default browser, there is no ability to choose a profile, or a private window.

That varies. Keep mind that often you can copy the link from the URL or from the app itself, go to the profile or private window, and then paste it over. And if it’s a direct link to browser, right click (or pressing and holding down on tablet) will open a context menu that will let you choose an option like “open in private.”

In the Quicken app window, there is no hyperlink.

However, there are now plenty of posts in the Quicken forum regarding this issue (for any browser), and I have reported the problem in the app, as they requested.

This thread can be closed?
Thanks for being here!

Jim A.

1 Like

@Moondoggy I just wanted to tag you in since this is your topic. Still needing help or going to go about it like jalles and want topic closed?