CBS Shows Not Playing In Brave

Does it work with Shields down?

no unfortunately not, and a major annoyance once you leave a site and go back to it shield is back on for that site. just got the new beta and same thing. both adblockers disabled, shield disabled, the initial commercial plays just fine. it’s just when it goes to play the show that it sits there.

Just adding that Version 0.58.18 Chromium: 71.0.3578.98 (Official Build) (64-bit) on Windows won’t play Amazon Prime and asks for Widevine even after the cache is cleared.

You need to install Widevine first (if you not install it yet). Widevine is disabled by default.

  • On Amazon Prime or other DRM-required site ( or else), look for puzzle icon at URL bar.
  • Install & Run Widevine.
  • It should working now.


does that just apply to amazon? cause spotify plays fine.


Widevine is required both for Amazon Prime and Spotify. If it’s not working for Amazon Prime (after installing Widevine), then you may want to “Allow all cookies” via Brave icon at upper-right. Or lowering the shields. IIRC, it’s a known issue.

Widevine is one-time install and applied to other DRM-required sites as well. :slight_smile:

so no needed for cbs then? just trying to figure out if unlike the suggestion above if widevine could actually be part of the problem. on a side not i did a test. i moved braves profile to the desktop, copied chromes profile to brave, and same issue. so whatever is going on with the videos on cbs has nothing to do with anything in my profile folder.

Widevine is reurired for many DRM protected media online. However, 1 - WV support for Linux isn’t available yet (in Brave) and 2 - after testing, I was able to view CBS videos without issue when Shields were lowered. Likely an ad-blocking situation.

You mentioned that you’d tried lowering Shields and it didn’t work but also mentioned that Shields seemed to toggle themselves back on. We just released a hotfix update for Release channel (v0.58.21). Download it if you haven’t already and try visiting the site/streaming again.

Let me know if the issue is resolved.

If not, I would very much like to see a screen recording of the Shields behavior you described above. Not because I don’t believe you, but it would be great to have it documented, as I’m unable to reproduce this issue.

thanks for the info, much appreciated. now about the hot fix, i’m assuming that’s for the release version since dev would be newer than this and release would be older than this “Version 0.59.21 Chromium: 72.0.3626.28 (Official Build) beta (64-bit)”? if that’s the case why not test in dev and then beta first rather than release? i ask cause i’m running beta and so far seems to update through update manager just fine. for now it’s no huge deal to go to one site through chrome until the beta is fixed.

o.k. took the plunge with the latest release version after completely uninstalling the beta. the hot fix does not work with at least cbs. on another note the release version does not have the webtorrent switch in settings, nor does the terminal command for disabling wentorrents seem top work with the release version. i’m back to the beta unless you have any other ideas, thanks

I’m really not sure what the issue is. Apologies for not being able to come to a solid answer. Again, I’m able . to watch videos without issue.
I notice that the loading wheel does hang a liiiiiiitle bit after playing the pre-roll ads, but no more than a few seconds and then playback is initiated.
To confirm, the site does work for you in Brave Beta?

dev, beta, release no cbs will only do the first ad and then just sits there on the player not advancing at all.

And you said that other streaming sits/services do work for you?

yea the ones i go to.

Further update: Puzzle icon offering to install Widevine does not appear when visiting Amazon Prime Video in the UK using the latest version of Brave (Version 0.58.21 Chromium: 71.0.3578.98 (Official Build) (64-bit)). However, it does appear when visiting and, once enabled, Amazon Prime Video works.

The process I followed was as set out here:
“Put shields down. Refresh. Check top right corner for pop-up icon. Right besides Brave rewards. Accpet widewine install. Watch netflix. Keep shields down.”

VIVALDI is your friend. i completely gave up on brave cause it’s nowhere near ready for prime time. a adblocker that you have to disable site by site, “rewards” program that can be disabled, the video playback issues, ect… after removing brave i decided to revisit vivaldi after a great article i read. it is now my default browser with chrome next, and firefox following up.

Yes, exactly. You can disable it entirely or, if your of a mind, configure them to work for any site in which you’re encountering errors caused by shields or by some content being blocked by them. If you visit a site that require cookies to be used and your Shields are set to Block all cookies - that’s not a Shields “problem”. That’s simply the result of blocking something on the page that it requires. Configuring (or disabling) Shields on a per-site basis ( if necessary) is a very useful tool, given that many sites will embed ad/tracking/fpp techniques within scripts, hide scripts within scripts, insert “hidden” cookies, etc, into required page elements.

I assume you meant to say “can’t” be disabled which, it absolutely can. Clicking the Rewards icon, go to Settings → Brave Rewards and toggle off the giant “on/off” button:

Also, CBS shows are working just fine under default Shields in Brave using release build v0.59.34

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.