CBS.Com not working correctly

I have a Mac and lately I have noticed that when I am on CBS.Com and with Shields Up there home page will not be displayed correctly (ie: the pictures and such). But with Shields down everything works correctly. It is like Brave treats them as an Ad and blocks them. This happens with extensions or no extensions does not matter and I have tried different settings and the only thing that will work is to turn off ad blocking. Also with uBlock Origin in Firefox or Chrome enabled that does work just fine.

Thanks for reaching out. I can reproduce this on my end as well. Looks like blocking ads/trackers causes the issue.

cc @fanboynz for a closer look. Only a couple errors in the console but likely relevant:

Glad to hear I am not seeing things! Anything that I can do?

Disable shields. Now everything appears up to par

i was just wondering if there any solution that has been figured out on my problem? I am still having it!

I tested that worked okay. I did fix an issue with paramountplus with live playback on bigbrother.

There home page was giving me problems the images at CBS.Com where being treated as Ads and where blocked with shields up. But the videos seemed to be playing ok tho! attached is a partial screen shot of there home page! I have a Mac.

Any filters enabled in brave://adblock? Not blocking scripts in shields?

No not that I can think of. When I first posted Mattches first answered and was able reproduce the problem on his end. The only thing that does work is to unblock ads either by turning shields off or going to the drop down and turning them off there and leaving shields on. uBlock Origin with Firefox does not have the same problem. Turning scripts off or on does nothing except make things worse.

Brave on a iPad works just fine no problems at (I know it is WebKit and different)

Can you test in private window mode, also try in a Brave beta profile.

Shows my settings, and the blocked items. The amount of blocked items may change, but it wouldn’t block any more than those selected url’s. Would be interested to see different url’s being blocked.

I have tried it with the Beta version and the same thing happens. And I have made sure in the installed components page ad blocking is is updated. I must admit I think I have tried it in a private window but I will make sure later. But I do know with all extensions disabled it does the same thing.

Screenshot of the blocked items? (similar to my screenshot)

I am going have get back to you later everything is off right now. Will post tomorrow.

1 Like

ok here are the screen shots of CBS.Com in there are 2. one of them is ads allowed and one with ads blocked.

Oops sorry I found the screen that you where talking about here it is!

The following is a screen of the beta version of Brave:

We’re not blocking, maybe adding @@|| into brave://adblock could resolve it. Are you using any extensions or additional filter rules or filter subs?

Tried @@|| and that did not work! I am not running any extensions that would affect that and anyways when using Brave Beta the same thing happens and that is a clean install nothing is added or changed.

How about adding @@||^