Can't log in to some websites on Brave browser

I recently made Brave my default browser. I searched the community for similar issues reported, but there was either no response to the OP, or the suggestions didn’t resolve my access issues.

Problem. When I try to sign in to certain websites that I have used for years on other browsers, the login operation silently fails (no error). After I provide my credentials and click the “sign in” or “log in” button, the screen does not change. I am not logged in, so I can’t access my account. This is not intermittent behavior. The login issue occurs every time on the 2 websites I’ve discovered so far.

Expected result. I should be able to log in to these sites to place orders, update auto subscriptions, change credit card expiration date, etc.

Steps I took to self troubleshoot. Nothing exciting. After going to or and providing credentials, the login page refreshes with prompts for uname/password.

Other things I tried:

  • Made sure Brave version is current (v1.57.53 Chromium: 116.0.5845.114)
  • Disabled Shields on problematic sites and refreshed. No change.
  • Restarted browser. No change.
  • Disabled uBlock Origin and Privacy Badger extensions, refreshed. No change.
  • Deleted cookies for the problematic sites. No change.
  • Changed password on problematic sites. No change.

What works. The only way I can access these sites is to open a private window on Brave or use a different browser (Safari or Firefox). I didn’t test on Tor.

Environment: macOS 13.5.1 (current) and Brave version 1.57.53 Chromium: 116.0.5845.114)

Additional Information: I don’t know why this happens on Brave only. Current versions of Firefox and Safari work with the same (active) extensions I use across all browsers. Most websites work fine since I switched, but these are two that I have caught so far.

Anything else I can try? It’s a minor nuisance to have to remember to launch Safari, and I would prefer to stay far away from Firefox.

1 Like

Honestly, this makes it sound like it’s an extension. Whenever it works for Private but not on normal, it’s 99% of the time due to extensions and like 0.5% due to cookies.

I see you mentioned disabling certain extensions and refreshing, but let’s have you try it on a new browser profile using no extensions.

Go to your hamburger menu image and choose Add new profile.

Once that’s done, make sure not to change any settings. This new profile should, by default, not be using any extensions. Test it. If you see it works and you can login to the sites, then it will likely confirm this as a problem. From there you’ll just have to try to experiment to see which of your extensions are creating an issue.

I created a login for seekinghealth and then attempted to login, I wasn’t able to log either. Though the same user/pass login didn’t work in Chrome.

aveneusa signed up and was able to login. Though I wasn’t able to login until I confirmed via email (must click on the link in the email).

The new profile worked, thanks. As fanboynz observed, I was able to log in to this morning using my normal browser settings (extension enabled).

I don’t have many browser extensions, so I’ll test uBlock Origins, Privacy Badger, Evernote web clipper, and my password manager.

I believe that Brave takes care of tracking and privacy issues, so perhaps I no longer need uBlock and Privacy Badger.

Interestingly, I encountered another site just now that did throw an error:

Access Denied

You don’t have permission to access “” on this server.

Error was returned on both my normal browser environment (with extensions) and in the new profile (clean). I was able to log in successfully to on Safari.

I saw a few community questions yesterday about “access denied” errors, so I’ll revisit those and test any solutions.

Nice to meet the human behind all those filter lists I’ve been using in browser extensions for years. I just enabled Fanboy Annoyances List because I hate those “before you navigate away” popups. Thanks for all you do, cheers!

Those access denied errors (seen on also) are related to VPN checks by the site.

I was unable to login to my account with Brave. I was using the Keepass password manager to type in my login credentials. I have used Keepass for years with no problem.

I tried logging in to by typing the same credentials from the keyboard. It worked.

After successfully logging in from the keyboard, I edited the Keepass credentials by retyping them into Keepass from the keyboard. Then I was able to login by allowing Keepass to type the credentials. I don’t think the Keepass credentials had any invisible characters in them since I had been able to login using Keepass from other browsers.

This site can’t be reachedThe webpage at

I get this when attempting to sign in, occurs in FF and Chrome also.

I cannot sign into another website with the Brave browser. I can sign in with Firefox. This is getting annoying. I will probably have to dump the Brave browser. I can’t spend my days troubleshooting browser problems.

The website I cannot logon to is my Synology Quickconnect account.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.