Google Voice not working only on Brave

Does google voice work with Brave? I normally open my gmail account, click on the phone at the bottom left which brings up the dialing panel to enter the phone number I want to call, I enter the phone number, then the call box panel opens on the lower right (all this is normal, same in other browsers), but then the calling panel just sits there indefinitely as if trying to make a connection. Usually at this point I hear the phone ringing until someone answers on the other end and the call proceeds normally, but not in Brave. In Brave the call box panel just sits there. Any explanations and workarounds?
Upon further exploration I see that both my microphone and speaker in the call box settings panel are blank. How do I grant access to these functions through Brave?
I tried enabling and dis-enabling cross-site fingerprint blocking, no change observed.
[Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) (64-bit)]
Happily using Linux Mint 18.3 Mate.

@cnapct
Thanks for reaching out to us. I believe that this is caused by the same root issue as this one:

I’ve added your report to the thread as a +1 and will see if we can get some developer’s eyes on it, since it has been sitting for a while.

Something recently changed because this was working for me last month (doing exactly what you did, using the voice dialer in the bottom left of gmail). Before, on first use, it had asked me if I wanted to allow the microphone when I dialed it for the first time (which I allowed) and it worked.

I think when I updated Brave last week it broke it.

Windows 10 x64 / Version 1.11.104 Chromium: 84.0.4147.105 (Official Build) (64-bit)

It seems to be working for me on my laptop using Mac Mojave and the latest brave ( Version 1.11.104 Chromium: 84.0.4147.105 (Official Build) (64-bit)). I couldn’t tell on my Windows system at work due to it not having a mic (or camera). But it did leave me some hints maybe - regarding making sure the mic isn’t muted… But anyway, could be a window-only issue (or linux as well) if your mic’s unmuted and GV still doesn’t work… You are using windows or linux?

edit: Missed the OP’s q:

Upon further exploration I see that both my microphone and speaker in the call box settings panel are blank. How do I grant access to these functions through Brave?

click the pad lock icon in the address bar and click site settings.

Hi Mattches, John Bradshaw, Vincent Jong,

Thanks for trying. I am using Linux Mint 18.3 and 19.3. I found a work around of sorts, it does not in any way provide a solution to the problem of not being able to make a phone call from Gmail using Brave as the browser as I can in some other browsers (FireFox does not work either). But, I can make phone calls using Brave as the browser as long as I open another window and then open Google Voice in that window. Google voice works fine using Brave. So I live with having two Google windows open (Gmail and Voice). Voice in its own window works for phone calls but no phone conversation from me is available from Gmail.

Specifically, from Gmail I can dial out, I can hear the phone ring in the other room, I can hear the person answer my call and talk, but that person cannot hear me reply, even though my mic is on. Same problem in Firefox

Thanks for your interest and help.