Can't download files securely - how do you turn this off

Hello, is there a way to turn off the “can’t be downloaded securely” messages where files I have requested to download are blocked until click through a bunch of times. I do not know what causes this, but I can assure the connection is secure and private not on an unsecured source.

I get this message more frequently now when I request a file download, and its a bit annoying for the browser to block my access to files (these are often system or product files from partners or clients, I use Brave for work tasks) because it thinks it knows better and stops me. I am wondering if there is a toggle to stop Brave from blocking downloads I know are safe.

@Utidiysyisitdixoxohd Well, guess let me first ask if you tried changing settings at brave://settings/security

If you turn off Safe Browsing…

No protection (not recommended)

Does not protect you against dangerous websites, downloads, and extensions.

But no guarantee it’ll work. Not sure if it’s being triggered by that.


Other thing I have to ask, do you have Upgrade connections to HTTPS turned on in your Shields settings? Not sure if toggling it might help, especially if it’s off.

One of the things that can cause the error you’re getting is if it redirects to an insecure HTTP connection to implement the download function.

After turning off all the protection security and disabling https upgrade I can download local files again. I wish this could distinguish between what is secure locally instead of stopping me from downloading from every URL it doesn’t recognize.