Disable the file download protection feature

Description of the issue:
Brave blocks some downloads and uploads for no apparent reason, basically stating that the file might be “risky”. I need to know how to disable this behavior, I have enough protection outside of Brave, and the block notifications are so subtle that I’ve missed them, then when I go back later for the file, I find that it had been blocked. Please advise as to how to disable this feature.
Steps to Reproduce (add as many as necessary): 1. 2. 3.
Download almost any installer and some PDFs, among other files, especially if the installer is an “exe” file.
Actual Result (gifs and screenshots are welcome!):
Files are blocked from download, Brave has to be told to “Keep” the file.
Expected result:
Brave will download the file without attempting to “protect” me. I applaud the feature, but some of us just don’t need it, and I can’t find any setting that will disable this.
Reproduces how often:
Frequently
Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 with Brave Version 1.50.121 Chromium: 112.0.5615.138 (Official Build) (64-bit)
Additional Information:
This behavior began several weeks ago. It finally disrupted my browsing enough that I began researching how to disable it, but found nothing, so I’m asking here.

1 Like

Hiya.
Can you try going to brave://settings/security and selecting ‘No Protection’ ?

Multiple computers, multiple OS. All block installs (EXE, MSI, MSP). Disabled all protections under brave://settings/security.

Nothing makes any difference. I have also tried a completely empty/new profile without anything synced no change. This problem started about thee weeks ago. I’m a systems admin by trade and don’t need to be protected from myself. This needs to be fixed. I really like Brave, but in my use case, this broken option makes it all but un-usable.

1 Like

seeing the same behavior. have to confirm exe’s that i intentionally downloaded etc. not a fan. should definitely be optional.

1 Like

Some here, very annoying that I have to click “Keep” in order for the download to finish. Happens for .exe and .msi. Probably other extensions I haven’t encountered yet. Please make it configurable at least.

1 Like

Same here for exes and msis. Whenever I click a download link, brave just plays some animation and that’s all. I had to guess that I should manually open downloads tab and confirm my actions there. Version 1.52.119 Chromium: 114.0.5735.90 (Official Build) (64-bit)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.