Can Brave updates be installed directly (i.e., not from links)?

When I use the ‘update’ links to update Brave I never seem to get the most current version.

I end up back on the Settings screen with another prompt to update to get the most current version.

For example, I updated several days after the last release – 1.23.73 – but when the relaunch was complete, I had
" Version 1.23.71 Chromium: 90.0.4430.72 (Official Build) (x86_64) "

Is there a way I can directly download and install the updates so that I get the actual latest version without having to go through the update process twice?

The links I’m referring to (that don’t update to the most current version) are:

(1) the one at the top on the far right of the screen (“Update”), and
(2) the one you see when you click on ‘About Brave’ in the Brave dropdown menu.

Thanks.

(I’m aware that the latest Release version as of the current date is 1.23.75. If I were to update via the above-cited links I bet I would now get 1.23.73 and a prompt to update a second time to get to 1.23.75 following the relaunch after the update.)

What seems to happen for me is that the update occus and shows the previous version. After hitting Relaunch the browser relaunches and then shows the newest version that I just installed. So for you, right now, if you’re on v1.23.73 and you go to About Brave:

  1. They update process will start
  2. Then it will prompt you to relaunch, still noting v1.23.73
  3. After relaunching you should now see v1.23.75

@Mattches We’ll soon see.

Right now ‘About’ is telling me I have 1.23.71 even though I updated to what I thought would be 1.23.73 three or four days after that update became available.

If I update and relaunch now, if you’re correct, I should then see 1.23.75.

Right now (before doing anything):

image

Yep – correct afaik.

@mattches Here’s what I see. Same that I reported earlier. Another prompt to relaunch to get to the current version.

Brave has already relaunched from the update I just executed, so regardless of what version it’s displaying in the dialog box (previous or current), why should I need to relaunch a second time to get to the current version (xx.yy.75)?

image

UPDATE:

Also, TOR window is still not working. Spins indefinitely, never loads. Same as before. Doesn’t appear to be a ‘version’ issue.

image

@mk7z,
We’re looking into the Tor issue.

If you click Relaunch again, does it now show the correct version?

@mattches Yes, but only after actually going through a second relaunch – meaning all the non-executables in the Dock get pulled again and Private windows close.

The current behavior seems to be one relaunch followed by a second mini-relaunch.

The behavior one would expect would be a one-step ‘update & relaunch’ (separate clicks for each if necessary) as all that’s required, wouldn’t it?

Q: If I were to click on the download link on this webpage – https://brave.com/latest/ – would it just install the update or would it open the newly-released version as a completely separate instance?

@mattches Just fyi, TOR works in this beta (& presumably in the latest version):

Version 1.24.71 Chromium: 90.0.4430.72 (Official Build) beta (x86_64)

@mk7z,

:point_up: This would apply the latest updates to the build you already have installed. You’re welcome to update this way if you’d like. Tbh I’m not sure what the issue is with your updating – I personally only ever have to update/relaunch one time per update.

I would comfortably wager that it is an extension you have installed or something on the system side that is forcing the extra step there, but I don’t know what it would be. I would also imagine that Chrome and/or other Chromium-based browsers would show the same behavior – do you have any other browsers to test?

@Mattches Thanks, I’ll try updating that way (from the ‘latest’ pg.) next time.

BTW, the issue didn’t occur when I updated Brave Beta. So that’s a second issue I’m having with the Release version that I so far haven’t had with the Beta (the other being the TOR window, still not working).

do you have any other browsers to test?

Other than Brave I usually only use TOR. I have Chrome but it auto-updates without user intervention, and I’ve only used it once recently, to test an issue that’s occurring with The Marvellous Suspender (The Great Suspender redux) in Brave that doesn’t occur in Chrome.