Bug: Auto-update does not complete the update (stuck at "Nearly up to date" after relaunch)

When I go to “About Brave” and see an update starting, it ends with a “Nearly up to date, restart Brave to complete the update.” message. However, when I click “Relaunch”, I always return to the same “Nearly up to date” message again when opening “About Brave”. When looking in the installation folder, I can see two version folders, the new one and the old one. The brave.exe launch always seems to launch the old version though. This also happens when an automatic update runs in the background while Brave is running. The only time the automatic update works as it should is when Brave is not running.

This behavior is new since not too long ago, but I can’t exactly remember when I saw it for the first time. Probably with one of the late 1.26.x versions of Brave Dev. When I get stuck with the “Nearly up to date” message, I have to download the installer from github and run it with Brave shut down, which always resolves the situation.

Current browser version: Brave Dev Version 1.27.88 Chromium: 91.0.4472.124 (Official Build) dev (64-bit)

@jek6094,
Thanks for reaching out to us.
Can I see a screenshot of the two versions in the installation folder? What is the version number of the other one?

I’ll post a screenshot when it happens again. It’s always the current version and the version to be updated to, iirc.

1 Like

Ok, I managed to get it to happen again. This is what is shown in the About Brave dialog:

This is the contents of the Brave “Application” folder:
brave-update-2

Every time I re-launch Brave in this situation, it launches the .92 version and displays the first image in the “About Brave”.

I’ll zip up the current folder structure in case there is something you want additional details about.

@jek6094,
Very interesting. I believe you should only have one of those folders in the Application folder (the one that corresponds with the newest version). I’m wondering if that is the problem here. I want to say try deleting it but before that, can you try applying the latest updates directly using the following Github link?

Running the installer with Brave shut down always fixes the problem. :slight_smile: It’s as if the executable renaming/old folder removal doesn’t work if the update is launched from inside Brave itself.

Very strange – I’ll have to reach out to the team about this and see if this is known. Appreciate you reporting.

1 Like

Same thing again, but this time I wasn’t triggering it by going to “About Brave”, I just noticed the green “Update” button in the toolbar:

brave-update-3

@Mattches Did you find something more about this? It’s still the same unfortunately, with the latest Brave Dev. :confused:

Thanks.

@jek6094,
Not entirely sure why this is happening. To confirm, when you select the Update option in the Menu, it appears to update and prompt you to relaunch but once relaunched it doesn’t seem to have actually updated?

Correct, it seems as if the relaunch procedure doesn’t do what it is supposed to do, which I guess is to remove the old version folder and swap out brave.exe and chrome_proxy.exe for the new versions. IIRC, this started late in the 1.26 Dev release series and has continued since then.