Brave Sync V2 is not working across my 3 devices

**Description of the issue: I was notified when I started Brave today that sync had been updated and so I went to try sync again after having issues a couple of months ago. I generated the sync code for another windows laptop and a qr code for an iphone (IOS). The codes were recognized on both, but after closing the settings neither device was synced with my main pc. It looks like each device started their own sync chain as no other device appears on the other. I will say though that this is much farther than I made it earlier this year.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Open Sync in brave settings
  2. Generate a sync code for a computer and a qr code for mobile
  3. Enter sync code in laptop and scan qr code for mobile
  4. Watch nothing happens.
    Reproduces how often:
    Reproduces every time I remove devices and re add them
    Brave Version(See the About Brave page in the main menu):
    Brave Version 1.12.112
    Type of devices currently running on the Sync chain in question:
    I’m trying to sync a desktop PC, windows Laptop, and an iPhone
3 Likes

@zach03160,
At this time, the Sync v2 implementation on iOS is being held up by the Apple app store, and is subsequently not yet available. This is why your data won’t sync to your iPhone yet. I apologize for the inconvenience.

2 Likes

Thank you for the Response! Do you know about why it is not syncing to my laptop?

2 Likes

@zach03160,
You’re syncing laptop to laptop and it’s not working? If you’ve configured everything correctly, you may need to close/quit the browser (on both devices) and relaunch before Sync “takes hold”. Can you try that and see if data Sync is successful?

1 Like

Hey,
I’m also facing a similar issue. I’m trying to sync my windows laptop to my android phone. I started a new sync chain on the laptop and scanned the qr code on the phone but it doesn’t seems to work. None of the device is shown on each other’s sync list - I guess they get on to their own individual sync chains.

I also tried it multiple times after clearing the data and cache on both the browsers, with a fresh install but it’s not helping.

Update - Just read that sync v2 is still rolling out for android (v1.12.x), so I’ll wait for few days and recheck.

1 Like

Same issue as @ashutoshv. Brave prompted me on Android to update my Sync to the version. Updated Brave on Windows 10 to latest version, started a new sync chain there. Scanned the QR Code on Android, and nothing… Both devices only those themselves in the sync list. I’ve redone this 10 times and tried entering the pass words as well. Still won’t show anything but the current device in the chains lists, so nothing syncs.

2 Likes

Is there any date when we may expect this to work for iOS? Within days and week(s) or rather many months?

3 Likes

Update 2 -
I recently got an update of brave mobile browser (android - v1.12.113), thus solving out the problem I was facing earlier. Now both my devices - mobile and laptop, are showing under the same sync chain.

I am able to send opened tabs from laptop to my mobile quite easily but it’s not working other way around. On mobile while sharing to laptop it asks me to - “Turn on sync to share across devices”, although it is already turned on, I double checked every setting.

Rest of the sync features are working fine for now. I’ll update here if I face another bug.

1 Like

@ashutoshv, @zach03160
Please note that iOS Sync is not yet available, which may be why you’re encountering the errors you see.

1 Like

Is there an ETA on when Sync v2 would be enabled on iOS?

I understand it is some sort of holdup with the store, just looking for an ETA. A week, a month, no way to know, is Apple looking at it, etc? Sync not working across all devices really kills the browsers’ usability for me. And not knowing v2 Sync wasn’t working, I installed v2 on my computers and now my mobile won’t communicate because it’s on v1.

@fdisk,
I do apologize for the inconvenience. I’ll reach out and see if there is an update to the iOS release timeline.

1 Like

Hi there,

I am having a similar issue on iOS.

Neither the scanning of the QR code, nor entering the “long code” works when I use them.

Basically as soon as I perform any of the above mentioned actions, my iOS device starts its own chain and none of the data from my PC chain is linked.

I really like using Brave but this issue forces me to choose another browser on my iOS devices.

Please advise.

@celebrimbor,
Please make sure you read through threads/replies before posting or commenting yourself. Just a couple replies up:

@Mattches
Please make sure to adequately inform your users before disabling important features!!!