Brave still slow- suggestions dont work

Brave browser is still running slow; loading web pages slowly( 10+ seconds or more)

I keep reading or getting replies with the same “fixes”; yet they dont work ( disable hardware accelerator, remove extensions, reinstall; etc, etc…)

Has anyone figured out why Brave loads pages so slowly without giving me the same typical fixes everyone suggests. Any real fixes or do i need to just dump Brave for a better browser.

Ive tested on Edge and Opera, both load webpages fine.

Hello @Brutus22 ,

I understand that you are experiencing performance issues with the Brave browser despite trying various suggested fixes. I apologize for the inconvenience this has caused you. Let’s delve deeper into troubleshooting and explore additional avenues for resolving the issue.

To assist us in diagnosing the problem accurately, it would be helpful if you could provide detailed information about your PC/laptop specifications. Please include details such as the GPU, CPU, RAM, and Windows version you are currently using. If you have a specific laptop brand, such as an Intel Evo laptop or Lenovo laptop, please mention that as well. Additionally, any information about when this issue started occurring, such as after a Windows update, driver update, or specific Brave version, would be beneficial.

Now, let’s consider some additional steps to address the performance issues:

  1. Create New Profiles: Creating new profiles can help determine if the issue persists across different profiles. If the performance problem is resolved in a new profile, it suggests that there may be issues specific to your main profile. This insight can help narrow down the potential causes of the problem.
  2. Disable Hardware Acceleration: Disabling hardware acceleration might improve or worsen performance, as it shifts the rendering workload from the GPU to the CPU. By disabling hardware acceleration, you rely solely on the CPU for rendering web content, which could potentially resolve performance and compatibility issues. If disabling hardware acceleration improves the situation, it could indicate a problem with your GPU drivers.
  3. Explore Additional Resources: If the previous steps haven’t resolved the issue, I apologize for the inconvenience caused. While waiting for official support, you may consider temporarily using an alternative browser that provides better performance on your system.

In addition to the suggested steps, I recommend referring to the following resource for further assistance: Browser Support and Web Compatibility on Intel Evo Laptops. This resource provides valuable insights into browser support and web compatibility specifically for Intel Evo laptops.

I apologize for any inconvenience caused by the performance issues you are encountering. The Brave community and support team are dedicated to resolving such issues and providing you with an optimal browsing experience. By providing detailed information about your system and following the troubleshooting steps mentioned, we can better assist you in finding a resolution.

Thank you for your patience, and please don’t hesitate to reach out if you have any further questions or require additional assistance.

Best regards,

@Brutus22 main issue is this isn’t a problem for the majority of people. So there’s a lot of testing and guessing to figure out what’s wrong with your device or installation. In terms of helping, one would need a little more information. I’m assuming based on your information that you’re on a Desktop version of Brave, but which OS and version? (such as which distribution if you’re using Linux, if you’re Mac Sierra, Windows 11, or what?)

In addition:

like i said, nothing fixed the problem. ive been thru this twice already- giving all the information you asked, and doing all the steps suggested. I guess Brave just isnt that good for my PC. i will change to a more reliable and better browser until Brave is fixed. thanks anyway

  1. most recent( updated)
  2. no
  3. all sites( even when i try to go to Brave setting its takes a long time)
  4. no, but i reset all just in case- still no fix
  5. yes, doesnt matter what profile
  6. still slow on Nightly

other browsers work fine- opera, edge, firefox, and google chrome.
disabled extensions- still slow
hardware accelerator off- still slow

really slow when i click HOME button( have it set to
when i click + to open new tab( set to homepage- google; but Brave dashboards opens quicker( yet i dont like dashboard cuz it has no search bar)- loads slow

Thanks for providing some of that information. That really doesn’t make much sense based on what everything you’re saying. Especially going by your original post that even going without extensions. Let me tag @Mattches and @steeven to see if they might be able to come in with more specific advice.

Can you please launch the Brave task manager and the windows task manager and share screenshots of them so we can see how many resources the browser is using?

Can you please try downloading and installing the Beta build and test to see if it also runs slowly or if it is just the stable install you have right now?

Apologies — I forgot that you’d already tested this on Nightly.
If I am being completely honest, this doesn’t make much sense to me. I don’t see any reason why Brave specifically would be performing noticeably slower/worse than other Chromium-based browsers.

I’ll have to reach out to the team for additional suggestions but while we’re here — as strange as it may sound — can you try disabling Brave News in the NTP, restart the browser and test to see if it makes any difference?