Brave Rewards claims HTTPS not enabled

As it says. I have the youtube channel all good, but the domain for the website, is not playing nice. It says HTTPS enabled in green at the top, but after uploading the identity file, it says there was a problem because HTTPS isn’t enabled on the website.

'Your website, xxxxxx, was not verified because HTTPS is not enabled. Please enable HTTPS on your domain, or choose another verification method.

I can access the website with https in a browser, and I checked the certificates in my cpanel, all seems well as far as I can tell. I’ve found other threads, but with no fixes and they’re all closed.


1 Like

Hi @weezul,
Can you try the DNS record method? It’s easier IMHO.

cc @Asad @steeven for additional assistance

1 Like

if you go https://xxxxxx/identity.file what you see?

if you go https://xxxxxx/identity.file what you see?

server 500 error

I was asked to place the file in a folder called .known-good which I couldn’t actually see, I think it was hidden but a manual navigation to it, let me upload the file.

I’ve just followed DNS instructions, and put it on my master domain and the subdomain (which I’m trying to get enabled)… still saying it can’t find the TXT. I assume this is where I should be, the DNS Zones editor? I’ll see if it just needs to propagate and try it again in a few hours.


@weezul you should put the DNS record on your domain, not subdomain. Make sure you put or @ as host/name of the TXT record.

1 Like

I double checked and it changed the entry to , i removed brave. and now it works. Sorry to bother you!

Edit: just to be clear, I was getting confused between a subdomain and a parked domain. It’s not a subdomain i was trying to enable, it was a secondary domain on a single server :slight_smile: Thanks again

1 Like

I may have spoke to soon. The sources are verified in my account (YT page, and website) but on desktop and mobile brave, it still says both are not verified. Is there a manual aspect to this as well?

@weezul basically, once you finish adding your site and you can see it’s listed under your publisher account, then it’s verified.

Your Brave require 24-48 hours to sync with latest publishers list. If it’s still shown unverified see Solutions for "not yet verified" bug

This topic was automatically closed after 30 days. New replies are no longer allowed.