Brave logs me out of my Banking website (ICICI Bank, India)

Hi Brave Team,

When I sign in to my Bank web site, it does allow me to sign in.

When I am inside the Bank Website, the moment I click any of the links in it (for example, links for accounts, credit card, statements, etc.), it immediately signs me out, and the bank site shows a page that “You are not signed in”. I have to sign in again, and the story is same in this attempt also.

I do not see this problem with my other Web Browsers (like Chrome, Edge, etc.)

Could you please fix this? Thank you.

Hi and welcome to the community. :slightly_smiling_face:

I am a community member too. Brave support usually don’t work on weekends, so going to try and help. Hope it does! :smiley:

  1. Have you tried clicking on the Brave Shield (far right of address bar) and disabling the Block scripts setting? Make sure “Block scripts” is disabled on every new page loaded. So, for example, disable at the login screen and check to make sure Block scripts is still disabled on the next page loaded. I notice when logging into some secure sites, this setting needs to be disabled again once you are logged in.

  2. If that doesn’t work, try with shields down. Again make sure shields are down for each new page loaded.

  3. You could also go to the website, click the lock to the left of site address, click Site settings in the dropdown and then change the site permissions.

Please post an update.

1 Like

If you go into shields, and Allow all cookies for the site, does it help with the sign in/out issues?

@dineshmj

In a Brave Browser > New Window, go to: brave://settings/cookies

Disable: Clear cookies and site data when you close all windows

Remove all: Sites that clear cookies when you close them

In the upper-right-hand corner of the window, notice the Search field. There, enter: icicibank

Screen Shot 2022-05-21 at 9.50.03 PM

Scroll down to: Sites that can never use cookies

Be certain, there, that none of the listed sources for cookies are, or might be, sources related to the bank website.

While still at the Cookies settings page, find: Sites that can always use cookies

Click the Add button

Enter [*.]icicibank.com:443 as the site, but Do Not Enable :

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Next, in a Brave Browser > New Window, go to: brave://settings/content/javascript

In the upper-right-hand corner of the window, notice the Search field. There, enter: icicibank

icicibank

Scroll down to: Not allowed to use Javascript

Be certain, there, that none of the listed sources for JavaScripts are, or might be, sources related to the bank website.

While still at the JavaScript settings page, find: Allowed to use Javascript

Click the Add button

Enter [*.]icicibank.com:443 as the site . . . but Do Not Enable :

  • Current Private session only

Click the Add button

Repeat those steps for adding a site source of javascripts, using the following entry:

  • https://icicibanksmartsearch.senseforth.com:443

Next, in a Brave Browser > New Window, go to: brave://settings/security

Disable: Use secure DNS

Do not use a VPN, for connecting to the bank - intending to Sign In.

Use a Brave Browser > New Private Window

But Do Not use a Brave Browser > New Private Window with Tor

Hi 289wk,

I did the steps mentioned in your reply. Thanks a ton, bro! Finally, I can work with my bank site in Brave Browser, although in a Private Session.

When I use a regular window, the problem is still there. But that’s Ok with me, I can use a Private Session tab for signing in to my bank’s site page.

Again, really appreciate your efforts and step-by-step instructions!

Have a great day!

Thank you, and regards

Dinesh Muciliath Jayadevan

@dineshmj Glad your problem was resolved! Can you please mark your post above or Fanboynz post as the solution so other community members (and support staff) know your issue is solved. Just click “…” in the options below the post and then click “solution” if it is not already displayed.

I tried these steps, but does not work in regular Tabs.

The solution proposed by “289wk” works for me. The only inconvenience is that I need to go to a Private Window every time.

1 Like

You are right. You should be able to access your banking website in a regular window.

You should open a support request to inform Brave support that although you are able to function opening a private window, Brave is still not working as intended. Just use the form linked below and select the General Issues category.