Banking website no longer recognizing Brave and will not allow login

For over a year I have been able to use Brave to log onto my Banking website using Brave on my desktop Mac.
Now, all of a sudden, I can not log on.
When I use Brave on my mobil phone I can log on without a problem.
If I use Safari I can log on to the Banking website as well.
I suspect a setting has change causing this.
Can anyone advise what might have changed on my Desktop Mac or Brave that is causing this.

Thank you

macOS BigSur 11.4

Version 1.25.73 Chromium: 91.0.4472.106 (Official Build) (x86_64)

1 Like

Hey @crnmker ! Welcome to the community :smiley:

Can you try clearing your cache and cookies to see if that fixes your issue? You can do this by going to the login page and clicking on the padlock in the address bar → Cookies and remove all entries you see there.


1 Like

Thank you for the quick response. I believe I have cleared both cache and cookies but I don’t see the padlock in the address bar?

Ok, I found the padlock and everything was cleared

Would you advise uninstalling Brave and then reinstalling?
Thank you

Not needed, just try to login again. Ensure the user/pass is correct…

1 Like

Thank you,
Logins correct!
Still not allowing login?

Try adjusting your shield settings when you’re on your bank’s site. Try changing block cross-site cookies to allow all cookies. If that doesn’t work, just disable shields. If that doesn’t work, Brave just isn’t compatible with bank site. Report broken site to brave…

1 Like

Thank you for the suggestions.

Shield settings completely off, cookies =allow all. STILL UNABLE TO LOG ON

Brave was used for this website for 14 months!! Then overnight I can’t log on. I did all the Brave updates as instructed. Like I said, I can use Safari or other browsers to access the site. And, more importantly, if I use my mobile Brave browser I can log onto the site!!

This tells me that it must be a Brave setting on this desktop Mac that is the issue.

Do you guys agree???

Does anyone suggest using the Restore Settings to original option??
Thanks again.

I’m having same issue with many bank sites. Also having same login issue w/ many insurance sites. All of which were working great for last 18 months since I installed Brave on my PC. Brave on mobile is just fine. I reported this to Brave and they only send me boilerplate responses…try turning-off Shield, trying turning-off/adjusting cookie control, clear cookies, etc.
Geez guys, If I wanted popups and security issues I would have stuck w/ Firefox.
Can Brave please look into this fairly new login issue w/ banks, insurance companies, etc??

OS Win 7 32bit

I guess I’m not alone!
Still no success here?

We have been testing various banking sites, but it’ll take a while. Since every user is testing in 3 test cases.

Shockingly my wife and I both have used Brave for over a year. We both use the same joint account on a credit union, a big and very well known credit union.
She has no problem logging into the exact same account that I cannot???

Try in private window mode, also if you’re using a vpn might cause issues

Thanks for that suggestion but it failed to be the solution!

Can you try a new Brave profile?

I already tried that!
Thank you
I’ve had to go back to Firefox
Works perfectly!
Thanks for your help.

@crnmker , would you mind telling what banking site it is? Maybe someone else with an account can confirm or help with the issue if we knew what site it was. (Obviously don’t post your username or anything… just the site.)

@labear, same, if you can post a couple of (banking/insurance) sites maybe we can focus in on the issue.

Also, knowing what kind of error messages you’re getting may be helpful – is it saying you put in the wrong password, or is some other kind of error being thrown?

Hi, I came across something similar issue on RIA money transfer site on a page used for tracking a transfer. But, I think I found the reason too. When I change the “Block all trackers & Ads” settings from standard settings to “Allow all trackers & Ads”, it is working good. I think somehow Brave considered it as an Ad.

Issue: Part of page fails to load. The area that is used to ask for a tracking number is failing to load. Works good on Chrome.

After I changed the settings as above it worked good.
@crnmker and @labear , please give a try as above.

Chase (URL:
B of A
and many other banks.
Also Delta Dental Insurance…and many other sites.
All were fine until about 45 days ago.
The issue is I get a “Your connection is not private” screen…see screenshot attached
Then I can attempt to open using the advanced selection and accepting the Unsecure option.
But even then, many times the site in question still wont open…and takes for ever to load if/when it does load.
It insane to think that Brave would have us disable Shields or Accept all cookies…then what is the point of having Brave.

The Brave support rep did try the above Chase Bank URL and says it worked fine for him. He provided a screenshot of his Shield details and it matched mine item for item.
Your thoughts?