Brave "incorrectly" thinks esxi and my ruckus AP are captive portals!

When browsing to my ESXI host page or Ruckus AP config page

I just see the following:
Connect to network

The network you are using may require you to visit its login page.
If I click the connect button it tries to take me here:

Expected result:
A login prompt to my ESXI host or Ruckus AP

I can replicate this multiple times but it only happens only chrome based and brave since last update.

Windows 10 Version 1.40.107 Chromium: 103.0.5060.53 (Official Build) (64-bit)


Some study material:

Internet has not been offline in about 6 month.
Only happens in chrome based browsers
I’ve tried creating new self signed certs from firefox for both of these and the issue is still present.
It even happens when I have a constant VPN to my employer which again proves my connection is not unstable.
additionally I read that post prior to posting here as I’m at a loss.

So the “Study materials” have not helped


Maybe try . . .

Go to: brave://flags/

Search for and Disable: Block insecure private network requests

If that does not fix your issue, then set that back to Default (as it was, before an adjustment).

Bit of info:

In a Brave Browser - New Window, go to: brave://settings/shields

  • Disable: Auto-redirect AMP pages (AMP - Google’s Accelerated Mobile Page)
  • (Alternate setting for older Brave Browser versions, try: Disable Enable De-AMP at brave://flags)
  • Disable: Upgrade connections to HTTPS (HTTPS EVERYWHERE toggle switch)

Next, in a Brave Browser > New Window, go to: brave://settings/security

  • Disable: Always use secure connections (‘HTTPS ONLY’ toggle switch.)
  • Disable: Use secure DNS

Next, go to: brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter: as the site . . . but Do Not Enable

  • Current Private session only

Click the Add button

Repeat those steps for the other IP address, too.

Thanks for the setting suggestions.
Alas it’s still the same …I get the feeling this is a “chrome” issue as these worked fine prior to that last update.

I’ve read a lot of this guys articles and those settings are the defaults I use at home and work.

Thanks again

I am not tech savvy and do not understand this issue. I am just posting a couple of issue reports that may be related. Please pardon if they are way off base and do not apply. :slightly_smiling_face:

Chromium Issue Report:
Issue 1340173: SUBJECT parameter not used in JSON string when setting Client certificate setting

Below are some of the “kitchen sink” troubleshooting steps. I am wondering if you have tried these. Maybe trying these things are “understood” based on the content of your topic? Please either educate me or ignore, up to you. :wink:

  1. Update to Brave 1.40.113
  2. Same problem in Beta and/or Nightly versions?
  3. Same problem with a new test profile?
  4. Clear cache/Restart: Brave, Computer, Network hardware/software
  5. Force update Certificate Error Assistant (and/or any other applicable components) at brave://components
  6. Check/Run certificate updates

There are probably other basic troubleshooting actions I’ve missed but leaving it here for now. Again, just wondering if these type things were tried or not and if not, why not?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.