Some sites have sudden problems in Brave

I have used Brave on Windows 10 for some time now, and I am currently using:

Version 1.25.68 Chromium: 91.0.4472.77 (Official Build) (64-bit)

The browser was working fine on Thursday 27th. On Friday 28th, some sites were no longer working in Brave, although they were still working normally in other browsers on the same machine (Firefox, Chrome, Edge), and in other older browsers on different machines, including older versions of Windows, and also in Chrome on an Android phone. The sites which I use pretty well every day and which broke overnight include:

https://studio.youtube.com

The way these sites have become broken varies slightly.

BBC News shows a very wierdly formatted page, as if the CSS is missing and the page has been formatted for a narrow screen.

Youtube Studio displays a completely white screen, nothing shows at all.

Movavi Tribe briefly displays the page as expected for an instant, and then goes to a white screen with a tab title of “undefined”.

The Worldometer site loads part of the page, but the country tables and graphics fail to load.

In each case, I am clicking on a link in a HTML page on my local network. There are other site links on the same page which all work perfectly well. As stated previously, all those links also work in other browers on the same machine, and had worked for many months in Brave. The page of links is served to my PC using http, but all the outbound links on the page are https. I will empahsise that the links page is completely plain HTML, no javascript, nothing fancy, just hardcoded HTML links, so that I can easily use the same set of links in different browsers on different machines. Needless to say, this page hasn’t been updated for months either.

I have tried turning shields off, turning off just about every Brave feature I can find, allowing cookies, scripts, everything, turned off the GPU acceleration, cleared the caches, cleared the history, rebooted the PC, all to no avail.

I have, however, discovered that if I copy and paste the link to those sites directly into the URL bar, the sites work perfectly well in Brave, so it is almost like there is some timing issue on the pageloads. If I just put my cursor in the URL bar and press enter it also works perfectly. However, if I use the refresh button, that makes no difference.

I stress all these problems started happening on the same day. Thursday evening, everything was fine. Friday morning, many sites were broken. I’m guessing Brave must have auto-updated sometime during Thursday. I figure that if the download had become corrupted then it would have many more glaring errors than this.

I don’t know if anyone else has ever reported anything similar, or if this gives you any ideas what might be going wrong? Any suggestions welcome.

Loaded all the sites quoted, seems okay here. Is it still an issue? are you using a vpn? @Olande

I too have this problem after upgrading to Version 1.25.68 Chromium: 91.0.4472.77 (Official Build) (64-bit) on Windows 10.

I also use a static HTML file containing hard coded URLs as my Home page. No java. Nothing special.

The website may appear blank or partially rendered. If I copy and paste the link or just go to the URL bar and press enter the page will reload properly.

This occurred after updating to the version noted above.

I have been using this method for over a decade with other browsers and for 2 years with the Brave browser without issues.

Some sites that I have problems with are:

https://www.medicare.gov/account/login/

https://www.walmart.com/

http://wowway.net/

Hi Khubbell, thank you for confirming that it isn’t just me. I did post a reply yesterday to fanboynz with a ridiculously simple html file that allows me to demonstrate this problem. When it is stored on my C drive, the links fail when I visit the sites with Brave. Serve the same page via http, and the links work fine. Like you, I have used this method for years, and it is specific to Brave and started happening without any changes to my machine config. However, the reply I posted did not appear because I am a new user of this forum and someone has to vet my reply before it appears. That was over 24 hours ago. I am surprised it is so difficult to report a bug. I wonder if this reply will fair any better?

  1. Visited https://www.medicare.gov/account/login/ seems to redirect, I’ll initially get a blank screen, then it’ll show a login option.
  2. https://www.walmart.com/ On one pass, it showed me a captcha (Anti-Bot check) then forwards me to the main site.
  3. http://wowway.net/ had some empty space issues, but the site showed. Have pushed out a fix for this btw (give it 24-48hrs).

Are you using a VPN? Does changing to Brave Beta build (via brave.com), change the outcome?

Can you capture the issue, upload to youtube?

Hi Fanboyz, no I’m not using a VPN. I can create a simple html file on my desktop with a single link in it to youtube studio, and when I click on that link, it takes me to youtube and the site fails to display correctly. Do exactly the same thing, but put the identical link file on a webserver somewhere and it works the same way it always did. This is consistently repeatable, and only applies to Brave, and only started happening a few days ago.

I’ve also found other problems have appeared too. Google Translate no longer translates, The Radio Times TV listings are missing part of the page and the mouseover features are not working. I suspect they are all connected in some way with javascript events.

I will try to put together a youtube demo to clarify this.

Just a quick test, before I head off to bed ^

Assuming you have passwords saved, If you can try brave://settings/clearBrowserData Maybe adjust the time range to clear the History, Cookies and Cache

I have already tried clearing everything. If anything, that just made the problems worse. Here is a youtube clip showing a selection of screenshots.

Remember, these are all mainstream well-respected sites used by millions of users. I’m sure there are plenty more examples of sites which have gone wrong but are less well known. These problems all appeared on the same day, and are all Brave-only problems. Firefox and Chrome/Edge handle these sites normally, no problem.

As a new user I can’t upload files. Therefore, I’m not able to give you an example. But it appears the issue starts with a locally stored HTML file with URLs pulled into the Brave browser. So instead on clicking on URLs in this tread build a quick HTML file with these URLs and try it yourself.

Thanks

From a site, that was also reported and saw issues: Seems to affect Chrome also.

I have installed Chrome on the same machine and checked they both use the same version of the Chrome engine. The problem does not occur with Chrome, or with Edge. In the fault report you referenced, it says “occasionally” break. That is very different from this which consistently occurs every time.

I was able to reproduce it in Chrome, which I took a screenshot of.

Okay, I hadn’t realised that was a screenshot. However, fact remains that the problem I am talking about is consistent not intermittent, and is limited to Brave only. Seeing your screenshot though made me realise the dev tools might contain useful info. I restarted the browser to get a clean console, and when I tried to open the youtube studio link, I had a screen full of errors saying:

Refused to execute inline script because it violates the following Content Security Policy directive: “script-src *”. Either the ‘unsafe-inline’ keyword, a hash (‘sha256-U8ARgYeCRRrmfEZa5U6fwc/K+mFGxfvDCSUSj2PQ25w=’), or a nonce (‘nonce-…’) is required to enable inline execution.

All of the sites I cited as problematical have this same error. The hash is different each time but there are always multiple instances of inline scripts being blocked. Remember, this error only happens when the page is opened from a link on a local page opened with the File: protocol, but the inline scripts are on the target page, not the link page.

Was there an update to Brave that fits in with the timescale I gave for these things stopping working?

Does that error message cast any light on what is causing this error bug in Brave?

Does refreshing the page fix it? When I initially get the broken page, a page refresh would restore it

No, refreshing does not fix the page, and neither does it make any difference if used in conjunction with ctrl or shift. Not sure if that changes the type of refresh that Brave performs, but I tried it anyway and it doesn’t make any difference. I’ve also tried closing the browser, clearing the caches, etc. It is absolutely consistent. The page doesn’t work (as illustrated in the screen shots I provided), refreshing never fixes it, but putting the cursor in the address bar and simply pressing enter again loads the page correctly. The only obvious difference I see between those two cases is that in the first instance the request has a referrer header of “file://…etc” and in the second it is empty, but the same is true in all other browsers, so it isn’t a case of the remote sites rejecting the “file” referrer.

I’ll also mention that I haven’t installed any extensions or anything. It is an “out of the box” installation of Brave and very little other software. I have tried turning off shields and everything else I could find to no avail.

Hmm interesting. Thanks for the feedback. @Olande

Can you try the previous release build? you may need to uninstall the current Brave build

I will try backstepping but it will have to be tomorrow now. We are on opposite sides of the planet so it is middle of the night now UK time. I will let you know the outcome when I try it.

1 Like

Version 1.24.82 has restored the functionality of the browser. I am now able to open websites as before.

I uninstalled version 1.25.68 but kept the settings. This was on Windows 10.