Brave freezes up frequently and regularly (video attached)

Brave freezes frequently when open. We’re talking every 15 second or so. I’m on the latest release (0.68.140) in Windows 10. I can hear the GPU fan spin up every time in sync with the hangups which last for about 8-10 seconds each time. Up until this point in this post, Brave has frozen up 6 times. I am not joking.

Here’s a screen captured video of the issue: https://cl.ly/111fed431b3b/Screen%20Recording%202019-09-25%20at%2011.53.25.16%20AM.mp4

You’ll see the first 28 seconds before I start using the address bar, everything is fine. CPU spikes can be seen on the process monitor.

2 Likes

A bit more information: I was thinking there might be one of my tabs that messed things up, or one of the extensions. So: I proceeded to test with just the start page tab (same thing happens), removed (not just disabled) all extensions (same thing happens). Then I completely uninstalled Brave (including wiping browsing history, cache etc.) and reinstall from the latest installer (same thing happens).

I installed Chrome to check if it is a “known Chromium” thing, but here it’s smooth sailing. No hangups, no lags/freezes.

I’d really, really like to get back on Brave though, so if there’s anything I can do on my end to help the dev team figure this one out, let me know (the issue is reproducible at this point).

@Mattches have we seen this before?

@gloom303 you could try disabling Hardware Acceleration. Go to the Settings page, under Advanced > System, and uncheck “Use hardware acceleration when available”

Also, is your computer connected to a Brave Sync chain? This could also be causing the issue – try unsyncing your computer from the chain.

If you’re could submit a crash report in this thread that would help!

Thanks for the tip. I did try disabling Hardware Acceleration (I work with real-time graphics software so I imagined it could be relevant), but the same behavior was seen after that (empty browser, just the startup-tab).

I am indeed connected to a Brave Sync chain. I will try reinstalling Brave, disabling that and report back.

I would be happy to report a crash report, though it’s tricky because Brave doesn’t actually hard-crash. It only freezes, and then gets unstuck, then freezes again after a while.

Just checking in with an update. I tried to be methodical, but it got a mixed up. I’ve uninstalled fully, and then reinstalled. I enabled sync chain (so I could remove it again), and install the two extensions I need (Dashlane and Grammarly). Initially, I believed the extensions might be the issue, but it was not (as disabling them did nothing to hinder the freezes). Next I removed myself from the sync chain, but the freezes continued. I therefore added myself back into it.

Next, I proceeded to disable hardware acceleration, and after a restart, it hadn’t helped. Then I tried to remove myself from the sync chain and THIS is when the freezes stopped. I’ve now been running without a freeze for 30 minutes straight, so as far as I can tell disabling hardware acceleration AND removing myself from the sync chain was the trick. There might be something to the order of actions, but I can’t really say with confidence.

Now: when I enable hardware acceleration, I can hear the GPU fan spin up again like before, but no freezes. However, when I activate sync again, everything goes to sh… well, back to freeze hell.

Any ideas?

2 Likes

I am having the same problem on Windows 10 and also macOS Mojave.

I first noticed it with 0.68.139 and it has persisted through 0.68.141. It also appears to impact the beta release as I’m experiencing the same issue on 0.70.100 (both Windows and macOS).

My experience is the same as @gloom303 's.

I use my email service in a Brave shortcut window, so this is a problem.

I am deleting my sync chain in the hope of finding a temporary remedy.

Possibly trying in private mode, with all extensions disabled? doesit help with the freezing?

My experience is identical and resolved once I disabled hardware acceleration and sync chain together. Thanks for all your work on this…

After a few days, I can confirm that disabling hardware acceleration and sync chain makes the freezing stop. Now, that’s hardly a solution, but perhaps it gives the Brave dev team (@Asad ?) something to focus on when debugging this. As a workaround though, it works.

I also have a Mac, and use Brave there. This issue was exclusively happening on my Windows PC, but after updating to Version 0.68.142 Chromium: 77.0.3865.90 (Official Build) (64-bit) on the Mac, it started happening there as well. Clearly, this is not an isolated incident.

1 Like

Glad to hear it! Yes, not a permanent solution by any means and we’ll most certainly dig deeper into this.

2 Likes

Thanks for the suggestion.

I’ve gone one-by-one through my extensions and none of them are causing the issue.

No, it’s the combination of hardware GPU acceleration and Brave Sync that seems to trigger it for at least me and another user. Disable both (as a workaround), and the issue should go away.

yeah its the sync chain. i ran brave problem free for a few days after wiping and unlinking, then re-enabled it again yesterday and crashes came right back.

this is on mac, no issue on my linux machine.

This topic was automatically closed after 30 days. New replies are no longer allowed.