Brave consistently and constantly freezing

Hello, I have just started using Brave. For the first hour or so it was running very smoothly, now it freezes for about 3-5 seconds roughly every minute that I am browsing. Since it happens so frequently I can’t tell if it is anything I am doing or if it happens at random, but I definitely notice that it happens more whenever I scroll up or down a page, or when I click on anything in the browser (be that a link to a website, or the new tab button in the URL). It happens when I scroll either using the track pad or the arrow keys. When the browser freezes, I can still move my mouse around but mission control and the dock are not available. I am running MacOS 10.14.6.

Version 1.0.0 Chromium: 78.0.3904.97 (Official Build) (64-bit)

1 Like

Sounds like one of tabs you have open crashes the browser. Usually I’d say it was probably the last tabs you opened but I don’t know for your case. You just got be able to isolate the trouble tab though. Isolate and report the site that’s borking brave…

Also you can have brave automatically send crash reports through Privacy and security or send manual at brave://crashes

It’s not to do with any particular tab. It happens indiscriminately, with one tab open or with several tabs open. It happens with any website as well, or even just switching tabs in the browser.

Hi @aryaman - thanks for reporting. Have you enabled crash reports? Have you tried to disable hardware acceleration? You can do so in settings.

The same thing happens to me, too, both on the desktop (Windows) and mobile (Android).
I tested on two different desktop PCs, and it doesn’t happen on a PC where Brave Sync is not active.

The freezes happen also with hardware acceleration disabled and the PC fan starts spinning during the freeze.

I’ve enabled crashed reports and disabled hardware acceleration but still having the same issue.

The issue seems to have resolved itself - I would guess from switching on crash reports but can’t say with 100% certainty which of the above steps fixed the problem.