Brave browser hanging/freezing since last update

Description of the issue:
Since the most recent upgrade, the browser constantly freezes up or had a lag. Even while typing this, it’s freezing up. It freezes when typing, while website are loading & when trying to scroll through webpages. It usually freezes for about 5-10 seconds before it starts moving again. Very frustrating.

How can this issue be reproduced?
It happens every time I use Brave. It actually froze up while typing this.

  1. Do any activity in Brave - type something
    2.Open a webpage
    3.Scroll on a page

Expected result:
Fix the problem so the browser functions normally again.

Brave Version( check About Brave):
Version 1.30.87 Chromium: 94.0.4606.71 (Official Build) (64-bit)

Additional Information:

Hi @Jodijode – do you have the same issues if you create a new profile and test it there?

I reported something similar the other day, in my case it’s most evident with Tab To Search, but I’m wondering if it’s the same underlying issue that you and I are both being bitten by.

It still seems to do it with the new profile. Maybe not quite as much but still happening. I also tried clearing my cache but it didn’t seem to make a difference.

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

This worked for me, thanks!

1 Like

You’re very welcome – happy to help.

Didn’t seem to work for me.

Do you have any extensions installed at this time? If you use a Private browsing window does the browser behave any differently?

Brave 1.30.89 just got released, can you update and see if anything changes? My issue (the one I linked earlier) has been resolved in this version.

Thanks for letting me know about the update. For some reason it wasn’t showing the update button in the right corner like it usually does. I now have it updated & even though I’ve only been using it for about 10 minutes, so far it doesn’t seem to be hanging up like it did before. Hopefully the problem is fixed!!

1 Like

I am having this same problem, and it is so bad as to be unusable (it froze three times while typing this reply). I have a few extensions installed but nothing out of the ordinary, and I am reluctant to reset them because I have data in the extensions I do not want to lose.

Brave also uses a massive % of CPU and memory constantly (multiples higher than Chrome when both are open with similar tabs). Metamask in particular takes 10+ minutes to even render, while even with Metamask closed and just scrolling on a webpage (or typing), there are regular freezes almost every 30-40 seconds.

I am at my wit’s end. I don’t want to switch browsers, but I cannot continue using Brave if anything close to this keeps up.

I have the latest version (Version 1.30.89 Chromium: 94.0.4606.81 (Official Build) (arm64)]), hardware acceleration is disabled, I cleared my cache, I restarted my computer, I tried using a fresh/new browser profile, nothing has worked.

Did you recently add any new extensions? If so, I would just remove those & see if you notice a difference.

No new extensions since the behavior started.

What did you mean by “reset them” (the extensions)? I don’t think I’ve ever seen an extension that you couldn’t temporarily disable without losing its data.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.