Browser lags when switching active windows

Description of the issue: When switching from another window to the Brave window on my Windows 10 PC, Brave and/or Windows noticeably lags/doesn’t respond. This happens whether I’m using the mouse to change the active window, or Alt+Tab to switch windows. I can notice this with just “about:blank” being the only tab.

The lag is only about a second, but it prevents screen updating, mouse movement, etc and is quite annoying.

How can this issue be reproduced?

  1. Open Brave
  2. Change the active window
  3. Change the active window back to Brave
  4. Repeat steps 2 & 3

Expected result:

Brave Version (check About Brave):
This happens with both Brave 1.0.0 Chromium 78.0.03904.97 64-bit and Brave Beta 1.1.5 (same Chromium).

Additional Information:
I’ve disabled hardware acceleration and have no syncing (initially thought this may be a duplicate of Brave freezes up frequently and regularly (video attached))

I also have Google Chrome installed (72.0.3626.121 64-bit) with hardware acceleration on, but Chrome does not exhibit the issue.

Hi @naaward,

Welcome to community, and thanks for reporting your issue. We released an update about an hour ago. Would you mind updating and see if the lag continues? Thanks in advance.

My current version is now 1.0.1 Chromium 78.0.3904.108 and the issue is still present.

With trying to pay attention to it more often now, this doesn’t seem to always happen. When I’m using one display, it hasn’t seemed to occur. I just observed the following behaviors in sequence:

  1. Connected to 3 displays, the issue was present.
  2. Switched to just 1 display, the issue seemed to go away.
  3. Switched back to the same 3 displays, the issue no longer seems present for now.

Thanks for the additional info @naaward. Let me know if the issue pops back up.