Brave crash after 10-30s


This morning I wake up, went on Brave and it was constantly crashing, I looked in the community and found out it already happened to other users, and some possible solutions were:

  • I tried to disable all sync setting - > didn’t work
  • I went to brave//flags and disable “enable brave sync V2” - > didn’t work
  • I disabled “hardware acceleration” and relaunch - > didn’t work

There are other possibilities to solve the issue?


Yeah. Same issue here. I had to reinstall the browser to make it work.

Do a resest settings. It might work. Profile might have got corrupted with an update.


1 Like

If you’re able to check brave://crashes/ before the crash happens, the Crash IDs from that page would be very helpful. It will allow us to take a closer look from our end into what may be interrupting your experience.

@sampson Really would be nice if somehow Users could access crash logs without actually having to dive into the browser. Is that possible/plausible to consider for the future or there not a means to do so? Just trying to think about the scenarios where the browser may not last long enough for them to submit the crash report and/or to get the report number.

1 Like

Hello everyone,

I solved the original problem by syncing my computer with my phone and t by going to “Program files”, “Bravesoftware”, removing “user data”, and uninstall and re-installing a few times and it worked.

After that the problem was that when i re-used the original “user data” it wasn’t working and by mistake i mixed some of the original user data with the new user data downloaded.

Now, that brave is new and not lagging, and since I’m having a problem with the user data, i tried to sync the new Brave with my original account but I’m getting this error.

“This code was generated by a deprecated version of Brave, please upgrade your other device first”

I searched in the community and i see you suggest using a tool to add a 25th word and i tested it and it’s not working.

Another option that you suggest is to download an older version and i tried and I’m not sure that i did everything right, so if you have a good tutorial, I can try it.

Other than this, there are other options to sync correctly my original account?

1 Like

It should work. Type the first 24 words and then then the new 25th word.
The 25 th word can be found from

(Make sure that your OS is on today’s date, it might be the problem)

I still get the problem, “This code is invalid”.

Also the 25th word is already integrated as last word when i copy the code from my phone, and it change every day automatically without going in [ ] and copy again the same last word.

(the time is right)

when i copy from my phone there are 24 words and the last one is the same of [ ]

so, 23 words + 2 equal words

Can you make sure both of your devices are using the most recent version of Brave? There was someone else who recently had this issue and it just took them updating the browser for it to resolve. I noticed you haven’t shared what version you’re using.

This kind of suggests what I was saying, that your device is outdated.

I just re-installed again brave from the official website ( Download Brave | Brave Browser) in my computer and I have the latest version in my phone since there are no updates.

@Alexey would you have any insight?


I don’t understand what happens

The error
This code was generated by a deprecated version of Brave, please upgrade your other device first
is produced only when some browser gets old-fashioned 24 words sync passphrase.

So this means that 24 words were provided.

My suggestions are

  1. Recheck device time and device time-zone. If time looks correct, but the timezone is wrong, then result of GMT time calculation is wrong => so time difference can be beyond 1 day => sync will not allow to join.

  2. Maybe something went wrong when while trying to use 25th word.
    The correct way to use 25th word tool:

  • if you have 24 words passphrase - you must add space and add 25th word.
  • if you have 25 words passphrase (generated earlier) - you must replace 25th word.
    in anyway, after these manipulations must be 25 words in the passphrase.

@Pep1, what are the browser versions on devices you trying to join the sync chain?

1 Like

Hello there @Pep1 I would recommend what @Alexey stated as this may be causing the Sync to not happen.

Let me know if that works.

  1. I confirm you that time & time zone (GMT +1) are the same in both devices.
  2. i have 24 words and i add the 25th. as i said before i have 24 words, and the last word changes daily, and it’s the same word i get from the tool you suggested to use…
  3. in both devices there is the latest version of brave. phone (1.45.116) and computer i just downloaded the latest version from the official website ( Download Brave | Brave Browser)

Having the same problem here.
Disabled all the same settings still crashes.
Went to reinstall brave and the installer failed.
Used offline installer from github and issue was still current.
Reset settings and still crashing.

I am posting this from Opera browser because as of right now Brave is unusable.

1 Like


Try disabling the cards in the dashboard.

still having the problem…

Same issue here. Just updated to MacOS Ventura 2 days ago. Currently running v1.42.97. I sent all the crash reports to the brave team. Been using Brave for over a year now, first time this is happening, in fact, first browser that has been behaving like this for me. Hope the issue will get resolved by the developers soon. At least all my tabs will still be here, although it’s annoying

Local Crash Context: 956499be-1303-4cd0-85e3-c051b7f5d51a

do you have Uploaded Crash Report ID: field for that crash at brave://crashes/ page?