Brave ads not appearing

I have set up brave rewards but haven’t been getting any ads, i assume the problem is that i don’t have brave appearing in my notification settings

Hello @reljonimo. If Brave notifications are not appearing in your notification settings run this simple tool and check again: https://www.bennish.net/web-notifications.html

I have brave notifications now in my settings, but still im not getting any ads

1 Like

Hi @reljonimo

First put off and again on all the options of brave where this is possible (in brave browser, brave rewards and in windows).

Second see if are live campaigns in your country here .

Third read this thread: FAQ: Why am I not seeing Brave Ads?

1 Like

I tried all of those and still no ads, and yes there is 1 live campaign in my country

@reljonimo,
It may take some time before you’re served your initial ads. Continue to browse normally and be on the lookout for them. If you don’t see any, at all over the weekend, please let us know and we’ll dig further into your issue.

I had the same problem but I solved it like this:

  1. disable brave rewards
  2. disable ads notifications
  3. disable self-contributions
  4. close the borwser
  5. reopen it and re-enable all the previous options (brave rewards, ads notifications and contributions)
    I received two ads in 1 hour and I see the reward in pending.
    In my case it worked, I hope you too!

https://community.brave.com/t/no-rewards-no-ads/114121/16

Tried it out, I was able to turn off the other buttons but couldn’t remove any of my tips. Today is ads payment day, let’s see if that goes through. Otherwise, Brave Rewards is just completely frozen on my end.

I just re-installed and reset settings to default, and it’s still not working.

Try this
https://www.bennish.net/web-notifications.html

I’ve tried everything and nothing works for me. This all has something to do with Catalina because my other computer that runs off of Mojave dose not have this issue with ads not working.

@firesociety,
How long has it been since you’ve had Brave Ads enabled?

@Mattches I never changed anything used to work up until I upgraded to Catalina end of last year. My brave ads have not been working since and i live in the US. Ive done everything even reformatting my hard drive resetting my router and all its a bug in Catalina because it works on my Mac Mini that runs Mojave OS

@firesociety,l
I’m using macOS Catalina right now (and have been) and have never had any issues with receiving ads, so there must be more going on other than the fact that it’s running on Catalina.
Can you confirm that you have Brave allowed to display Banner and/or alert notifications in System Preferences --> Notifications.

@Mattches Yes, I have my notifications on

Is there anything you can do to help?

@firesociety,
Perhaps – can you open your own stand alone thread and including as much detail surrounding your issue/setup as possible so it’s easier to track and I don’t get your information mixed up with others in the thread?

@Mattches I did and no one has replied to my thread, Also I figured out that If i do not have my browser in Full-Screen mode then my ads start to work. A little annoying but thats what i have been doing since i figured it out.

@firesociety,
I believe that that is the intended behavior.
When any application’s “full screen mode” is detected, ads are to be halted – this is to not interrupt users who are, for example, watching a movie or gaming, etc.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.