Bookmarks bar disappears almost instantly (bug)

When enabling the bookmark bar setting under “Always show bookmarks on new tab page”, the bar disappear after a split second on the new tab.
It seems to be a bug.
It can be seen in this webm video:

It’s a great feature only if it could work.

@AccessDenied Would you mind updating Brave? You’re using older version (yours shows using 1.48.164 whereas current version is 1.49.120). Also, can you confirm which OS you’re using? What’s intriguing to me is the difference between our Settings. For example, screenshot of yours is below (which you’ll notice you have it disabled, saying it can’t show Bookmarks):

While screenshot of mine is below:

Not sure if it’s due to OS or if due to Brave version, but you’ll see mine doesn’t have an on/off toggle like yours, but instead is a drop down box where you can decide how you want bookmarks to be shown. When I select Only on the new tab page it works well.

Thanks for your response!

I upgraded to 1.49.120 and I now have the same drop-down menu as you.

HOWEVER, when I open a new tab it does not display the bookmarks bar despite choosing “Only on the new tab page”. The bar just flashes and quickly vanishes when opening a new tab…
I’m using ubuntu 22.04 OS.

@AccessDenied do you have any extensions by chance? If so, I’m wondering if they might be causing problems. One way you may be able to test this is to open a New Private Window and see if it works. I know I just tested and the new window had bookmarks but once I went to a different site, the bookmarks went away.

Btw, might be able to run through some ideas or hope others pop in here over the weekend, but official Support like Mattches likely won’t be on for the next couple of days. Just making sure you’re away might need to wait it out if basic troubleshooting yields no results.

No extensions. It’s a clean install. Tried it on other Ubuntu 22.04 systems as well with the exact same issue. Perhaps it’s a Linux issue. Would be excellent if it could work, though!

Hmm, interesting. I’ll tag @JimB1 in case he happens to pop in over the weekend. He’s another normal User who is active here on helping others. He has a lot of technical knowledge and is a person I often try to tag in on issues related to Linux. Maybe he’ll have some thoughts.

1 Like

Thanks mate.

Update: Exactly the same phenomena occurs in Windows 10. I’ve gone through all settings carefully but really can’t find anything obvious :confused:

Update 2: It works in Private Tab! Both in Ubuntu 22.04 & Win10, works in private/incognito, but not in normal window.

Could you try in a new profile?

I found the problem.

The “New Tab Page” is set to “Homepage” in the dropdown menu.
My homepage is custom URL
When “Dashboard” or “Blank page” is chosen, the bookmarks bar behaves as it should.
However, in Private Window all three options will let the bookmarks bar behave as intended.

It should still be considered as a bug because “Homepage” is indeed an option under the “New Tab Page” and do fully work in Private/Incognito Window.

I really hope someone at the dev team can enable this particular bookmarks bar option for the Homepage aswell, not only “dashboard” and “blank page”.

I appreciate your response. Thanks!

1 Like