Bookmark Bar in New Tab Page


In the Brave settings, there is an option, under brave://settings/appearance, named “Show bookmarks”, with the following options:

  1. Always
  2. Never
  3. Only on the new tab page

If you choose the third option, Only on the new tab page, it will function correctly until you ever have to manually show/hide the bookmark bar.

How can this issue be reproduced?

  1. Change the “Show bookmarks” setting under brave://settings/appearance to ‘Only on the new tab page’.
  2. Close the settings.
  3. Verify that the basics of the setting are correctly functioning by open a new tab.
  4. Navigate to a site by entering a URL, such as https://brave.com.
  5. Notice that the bookmark bar correctly hides.
  6. Manually show the bookmark bar again by pressing the shortcut key, on Windows, Ctrl + Shift + B.
  7. The bookmark bar should now be displayed.
  8. Hide the bookmark bar by pressing the shortcut key again, on Windows, Ctrl + Shift + B.
  9. The bookmark bar is properly hidden.
  10. Open a new tab by pressing the shortcut key, on Windows, Ctrl + T.
  11. Notice that the bookmark bar is not being displayed. This is incorrect behavior.
  12. Go back to the settings page, brave://settings/appearance and notice that the “Show bookmarks” setting is changed to ‘Never’.

Expected result:
Manually showing/hiding the bookmark bar should not change the “Show bookmarks” setting. If the setting is set to ‘Only on the new tab page’, the bookmark bar should always be displayed when opening a new tab, regardless of whether I have ever previously manually shown/hid the bookmark bar.

Brave Version( check About Brave):
Version 1.63.169 Chromium: 122.0.6261.111 (Official Build) (64-bit)

Additional Information:
You can use Google Chrome web browser to test and experience the correct/desired behavior that I described in the Expected Result section.

Activate “Always show bookmarks on new tab page” in settings.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.