Block autoplay on bitchute

I have the permissions of the site Bitchute set to disable autoplay but about 40% of the time when I open a video link it will simply start playing as if the setting was default.

This behavior is consistent across 3 separate windows machines both w10 & w11.

Version 1.52.126 Chromium: 114.0.5735.133 (Official Build) (64-bit)

Additional note: When this unintended behavior happens, refreshing the page any amount of times will still open the page with the video autoplaying. I must close the tab, wait a few seconds and reopen last tab or reopen from original link for the video page to load without autoplaying.

This is becoming very frustrating.

@2zrfe18 Just out of curiosity, what do your settings at brave://settings/content/autoplay look like?

Allow sites to autoplay videos is enabled

under Customized behaviors

Sites listed below follow a custom setting instead of the default

Bitchute ## Block

I didn’t realize there was a global autoplay setting

I will disable that and see if the issue persists

1 Like

You read my mind. I’m wondering if there’s some sort of issue on the links or something. It will be interesting to see if perhaps it will make a difference.

Other thing I’d inquire on is on extensions. So if global setting has no impact, that likely will be next thing I’ll ask you to test.

1 Like

doing some testing today with global autoplay disabled

Videos will still play sometimes and ignore the setting, but the frequency seems noticably less. Refreshing seems to stop videos that autostarted which is good.

I recalled never having issue with firefox’s autoplay block, but testing it after having not used the browser for years I found the problem persists with it in Bitchute as well

@fanboynz and @Mattches would either of you have any clues on why this may be happening?

This behavior is inherited from Chromium. Discussion of this topic (uncontrollable ‘autoplay’) has a long history: in the query box (upper right corner of this page), search ‘autoplay’.

My experience: Brave’s ‘autoplay’ settings (the link supplied by @Saoiray) are somewhat effective, but only … somewhat. Having tried the Brave settings and having found they failed to do the job, I continue to use

Any referral to any extension MUST be accompanied by a warning: good extensions can and do go bad. Use extensions cautiously and minimally.

1 Like

@2zrfe18 @redbike9,
It may be related to Chromium in some way or another — however, I cannot reproduce this behavior on macOS or Windows 10 systems. On my end, if I set the Autoplay site setting for Bitchute to Block, content does not play unless I expressly tell it to. I tried with several videos and refreshing the page multiple times, as well as in different versions of the browser.

I have not changed any settings other than the Autoplay site setting for Bitchute specifically so I think something else must be going on here. As @Saoiray stated, I’m curious if there are any extensions you have installed at this time that may be causing the behavior?

Currently I only have reddit enhancement suite installed

I am an extension minimalist

The built in autoplay in Chromium/Brave is some what limited, If limiting autoplay is important an extension maybe a better option here.


OK I see

It works well enough now, considerably better after toggling the global autoplay off. It’s only about 1 in every 10 links I open now instead of 4 of every 10. I can live with that.

Thank you all for your help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.