400 error when I try to sign in on Brave to gmail, can sign in on Google

Hi everyone! Get this 400 error when trying to get to gmail account on when using Brave browser. Opened the Google browser and can sign in without any issues.

Found some Youtube videos, one said to delete all history, cookies, etc - did that, no luck. Another said to go to Chrome and do a couple more things, which I did, again no luck.

anybody got any solutions for me to try please?

Thanks, TC

1 Like

Hi

Create a second profile (by clicking on settings then create a new profile - Name the new profile TEST ) and from there try to login to gmail account.

If this goes well, delete the new profile ‘TEST’, open the old profile, open gmail and stop extensions one by one to try to find out if one the extensions causes the problem.

Result?

Hi there! Thanks for taking time to reply. so as soon as I enter gmail.com in the search bar, it immediately comes up with the error page, so I won’t be able to create the TEST profile in Brave.

Also, as I can’t get into gmail, how would I stop the extensions (and exactly where do I find these extensions listed, please?) once I do get in?
Thanks!

TC

Hi

Do you use http or https? Try to open this link https://community.brave.com/

In Windows OS,

Same situation here. Plus the Brave Rewards got disconnected from Gemini and can’t re-connect. No support whatsoever.

Time to go back to Firefox.

I was able to create the new profile test, and I was able to successfully log into gmail. I can’t find out how to delete the test profile, but I did go back to my regular profile and deleted all three extensions that were then, and then tried to log in to gmail, but still get the same 400 error!

Hi

Set Brave shield to standard as shown in All of the google products which require sign in show Error 400
Do you use VPN?
Do you use secure DNS?

Yes, I use NORD vpn

I am not sure whether or not I use a secure DNS! (Sorry, I’m not that technical)

But here’s one thing that might help, when I try to log in using “New Private Window” in Brave, I still get the same error. But just now I accidentally clicked on “New Private Window using Tor” and although I had to do a translation from Dutch and then verify a code sent to my iPHone, I was able to log in! But still can’t do it on the regular Brave screen.

Thank you, I managed to delete the TEST profile! I’m learning! :slight_smile:

TC

and I’ve tried disconnecting the VPN and logging in without it, still the same error!

Hi

  1. Open this link in Brave brave://settings/clearBrowserData
    Check Browsing History, DO not check cookies, Nor Passwords, then clear data. .

  2. Open command as administrator, then flush DNS by pasting and entering ipconfig /flushdns

  3. Restart laptop.

Hi again! I did all that, and after I’d done the flush DNS as Admin, I just tried to log in on that same screen to gmail, and I was able to.

Then I logged out as Admin, restarted PC, and logged back in as myself, but still get the same error message! Ugh!!

I sure appreciate you sticking with me and trying to resolve this issue. Thank you!

TC

Hi

From what I know no one solved this issue. But this happens for older versions of Brave.
So, leave the post open maybe someone will look more into it.

Disabling the ‘Brave Shields’ seems to work for me. Click the icon that looks like the head of a lion and disable the shields.
image

1 Like

Yay! It worked!! Thank you SO MUCH! After I disbaled shields, a pop up came up and asked if I was having issues with the page and I described what happened and all that I had done (be referring them back to this chat), so hopefully they will look into it to get the issue fixed! Thank again!

1 Like

This resolved the issue for me too. Thanks for the easy solution, but I sure would love to see this resolved in future updates.