All of the google products which require sign in show Error 400

Description of the issue:
Google products such as Google Meet / Drive / Mail / Calendar which require me to sign up aren’t working all of them show me a Error 400 with the exception of google meet which shows “Something went wrong please try again” which is similar to 400. YouTube is working fine since i haven’t signed up on it. It was working perfectly before. One more thing to notice would be that this happened after I needed to open a meet call from two accounts and signed in from brave and google chrome browser to use meet, did it for 2-3 times and soon all the google products stopped functioning on brave.
Exact URL of the website in question:

Did the issue present with default Shields settings? (yes/no)
yes default just trackers and ad blocked are set to aggresive

Does the site function as expected when Shields are turned off?
No even after turning off it doesn’t work
Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
No I don’t think so.
Does the site work as expected when using Chrome?
YES
Brave version (check About Brave):
Version 1.26.74 Chromium: 91.0.4472.124 (Official Build) (64-bit)

This is the error shown everywhere.

Check the following:

  • Go to brave://settings/extensions and make sure Allow Google login for extensions is enabled.
  • Go to brave://settings/cookies and make sure you’re not blocking all cookies but only third-party cookies.

No. 1 made no difference. I have been using brave with that setting for over 2 years now. But I did enable it still no difference.
No. 2 It is set to only third party cookies only

Thank you for replying.

Have you tried after clearing your browsing data?

You can do that at brave://settings/clearBrowserData.

brave://settings/clearBrowserDataAdvanced → Time range: All time → Select all options → Clear data.

If you don’t want to clear your browsing data, you could try with a fresh user profile, that would at least eliminate issues related to browsing data and extensions.

1 Like

Okay I created a new profile and mail opens now. Can you tell me why this happened? Also what do I do now like how do I transfer all my data?

Yup just checked all of them work now.

Are you using any extensions? The issue you’re experiencing is either related to your user profile’s browsing data or/and some extension.

So should I remove all my extensions and check. What if extensions pose no issue but the browsing data?

Removed all the extensions. But no change. Will I lose all my data if I need to fix this issue? By browsing data do u mean just my search history or everything including bookmarks

The easiest way to check whether extensions are the source of your issue, simply try to open the websites in a private window (Ctrl + Shift + N). Unless you have explicitly configured extensions to load in private mode, a private window won’t load any of your extensions.

If the source of your issue is your profile’s browsing data, you could easily clear the browsing data. Is there anything in particular that bothers you with clearing the browsing data?

I’m just concerned browsing data shouldn’t delete my bookmarks/saved passwords etc. idc about search history.

Bookmarks won’t be touched regardless of which browsing data options you select. For passwords, uncheck the Passwords and other sign-in data option.

Note: There is a known bug that clearing Site and Shields Settings browsing data resets the global Brave Shields settings. You’ll have to re-adjust the global Brave Shields settings at brave://settings/shields after that.

@Rethanis Thanks man!!! (or woman as applicable) Really saved my headache of all these days. Bless You !

1 Like

You are welcome, enjoy your browsing :wink:

1 Like