Cannot log in to gmail (Error 400) after updating Brave

Description of the issue:
After updating Windows (Feature Update for Windows 10, Version 21H2) and also updating Brave Browser, my Gmail stopped loading.

Steps to Reproduce (add as many as necessary): 1.I cleared all cookies and all browser history. 2 I went to gmail.com and entered my ID, my password, and my 2FA code. 3. In fact, I tried this several ways, Youtube 2FA, Google Authenticator 2FA.

Actual Result (gifs and screenshots are welcome!):
The result every time is Error Code 400, which says the request is malformed and that Google doesn’t know anything else.

Expected result:
If I use a different browser on the same machine, e.g., MS Edge, after entering ID, password, and 2FA code, gmail opens normally.

Reproduces how often:
So far, every time I clear all the cookies from gmail, I am able to start the normal log-in process. But after completing the login process, gmail does NOT open properly the way it does on Edge. Instead, I get the Error 400 page.

Operating System and Brave Version(See the About Brave page in the main menu):
My operating system is Windows 10.
Browser is Brave Version 1.37.111 Chromium: 100.0.4896.79 (Official Build) (64-bit)

Additional Information:
I have submitted this problem to the Brave developers using the “broken site” link – using the Error page that appears right after a completed proper login sequence.

2 Likes

Hi

Disable Brave Shields.

Oops. I forgot to mention that I also turned off Brave Shields as part of my effort to get Gmail to load. That makes no difference. I still get –
image

2 Likes

Same problem here. This problem also occurs when I go incognito mode

1 Like

Same problem here, any ideia?

2 Likes

Same here, it does not even allow submit it again, have to close the browser, open it and again “400” after entering the password.
Chrome, Firefox and Opera opens it normally.
What the heck is going on?

1 Like

Same here, it started today after a macos and Brave update.
I’m unable to sign in to any Google services (gmail, drive, docs, calendar …)

1 Like

Here are a few things to try in this post. Hasnt worked for everyone, but has for several.

What I have been able to figure out is this is an issue with the google Crome engine not wanting you to use their sites without being subject to all of their advertising. I was having the same problem but if I disable all brave shields for google G-mail log on screen at the error page and then refresh it it will log right in, BUT after that when I open up a youtube video I’m automatically logged on to youtube because I’m still logged on with my G-mail account as is normal but even though I have NOT disabled brave shields for youtube it doesn’t matter they will be disabled for youtube as well and I get all of the ads. NOW if I open a youtube video when I’m not signed in with my google G-mail account all brave shields are still up and working fine and no ads. So my conclusion is this is googles doing and doesn’t have anything to do with Brave I don’t think. Likely a bug programed into the crome engine on purpose to force everyone to view their advertising. So Brave developers you might want to think about putting together a Brave version with the Mozilla Fire Fox engine and ditch google all together.

1 Like

I’m also getting the same error when trying to open any Google service. Also, oddly and possibly not related, I cannot open pdf files any longer in Sales Force within the browser. It just states it refused to connect to the server that sends the file.

I had the same issue in Linux Mint

Wondering if anyone here can perform this test for me to see if it resolves the issue:

I watched carefully as I went through the login steps, and Brave Shields were down all the way until the Error 400 page came up. That page had Brave Shields ON. So I turned them off!

PROBLEM SOLVED. GMAIL LOADED.

1 Like

I am having the same problem. I uninstalled and reinstalled the browser but cannot log into any google site.

I also deactivated the shields, turned off the extensions, and performed a clean install on the pc.

Does anyone have a solution or will I have to go back to Edge again?

Thanks in advance…

1 Like

thanks wizzin, that solved the issue for me!

what I did was to set brave shields to “down” on the gmail login screen, they stayed down through the rest of the logon process (pw and 2-factor authentication) and then gmail loaded.

I have tried other proposed solutions (clear browser data, cookies only on 3rd party, open it in private window) which had made no difference.

1 Like

The same problem on Fedora 35, all shields are down cookies cleared. I can login to google account but 400 on Gmail and some google services

@iamjacklope ,

Yes, Signed In to Google’s One Google Account, means that you are Signed In for all:

One_Google_Account_for_Everything

For access to G-mail via webmail (using Brave Browser) . . .

All of the following steps, assume that you normally wish to have / leave Brave Browser > Shields: UP

Including the Global Shields Settings:

Global_Shields_Settings

Therefore, you figure out what sources for cookies, and sources for scripts, are needed for access, and thus:

With Brave Browser running, in a New Window, go to brave://settings/clearBrowserData

Examine all the settings for all three tabs: Basic / Advanced / On exit

Be certain that those settings are what they should be, for your usage. In time, you will have tested those arrangments, and figured out what you need, there.

Be certain for two of the tabs – Advanced / On exit – to Disable: “Site and Shields Settings” (unless, before the following steps, you decide that you initially do need to clear “Site and Shields Settings”).

IMPORTANT: The cleaning / clearing away of cookies, thru that (brave://settings/clearBrowserData) processing, MIGHT NOT REMOVE ALL of the cookies! If you are intent on removing all cookies, then you must also, in a New Window, be sure to go to: brave://settings/siteData and manually remove sources for cookies, if any, there.

Recommended at: brave://settings/cookies

  • Disable: “Clear cookies and site data when you close all windows”

  • Do not use: “Sites that clear cookies when you close them” (better to clear those cookie sources, manually: brave://settings/clearBrowserData)

Quit Brave Browser. Wait a moment. Start Brave Browser.

The following entries of sources for cookies and scripts, can certainly be tested / tried, one at-a-time or in combinations. But, given that Google has been re-arranging the furniture, you probably will end up needing all the entries listed.

In a New Window, go to brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter accounts.google.com:443 as the site . . . but do not Enable

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for the following entries:

https://[*.]firebaseapp.com:443
https://[*.]google.com:443
accounts.youtube.com:443
docs.google.com:443
gmail.com:443
mail.google.com:443
www.gmail.com:443
www.google.com:443
www.youtube.com:443
youtube.com:443

Next, go to brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter accounts.google.com:443 as the site . . . but do not Enable

  • Current Private session only

Click the Add button

Repeat those steps for the following entries:

accounts.youtube.com:443
apps.google.com:443
docs.google.com:443
meet.google.com:443
play.google.com:443
workspace.google.com:443
www.google.com:443
www.youtube.com:443

Sign In processing may include a password plus 2-factor authentication.

If still unable to Sign In . . . then, the list of sources for cookies and the list of sources for scripts, probably need to include, one or more sources that are discovered during those stages of that Sign In processing.

I do not have a G-Mail account, with which to discover the probable additions, via Developer Tools.

Developer Tools > Network tool is where you search for sources of scripts and other items that will qualify despite their not being obvious scripts.

Developer_Tools_-Application-_Cookies__example_Amazon.com_00

Developer Tools > Application tool is where you will find the sources of cookies.

How to use Developer Tools

https://www.lifewire.com/web-browser-developer-tools-3988965

https://developer.chrome.com/docs/devtools/network/reference/

https://docs.microsoft.com/en-us/microsoft-edge/devtools-guide-chromium/

2 Likes

THANK YOU! Adding the cookies and javascripts has resolved my issue!

2 Likes

In my case, the solution was to remove google.com at brave://settings/cookies from the list of sites that clear cookies when they’re closed. Shields are up.

2 Likes

@espilva ,

Also, at: brave://settings/cookies

Disable: Clear cookies and site data when you close all windows