Gmail stopped and google voice stopped working in Brave

I can access my gmail using Edge, but Brave gives me the following:
400. That’s an error.

The server cannot process the request because it is malformed. It should not be retried. That’s all we know.

I cleared my Cache and nothing helped. Another weird thing that happened today is I started seeing YT ads today for the first time. Brave has always been extremely reliable, but something is definitely wrong.

Hi

Does it say Fix Gmail Error 400?
Give me a screenshot of the error.

Hi

This is a tricky issue.

  1. If you are using VPN, disable it.

  2. Clear, browser cacher, cookies, and password related to google.
    go to brave://settings/clearBrowserData
    go to brave://settings/passwords?search=pass

  3. Desactivate browser extenions.

  4. Allow google login go to brave://settings/socialBlocking

  5. Disable fingerprinting blocking go to brave://settings/shields

  6. Open Command Prompt as administrator and enter ipconfig /flushdns

  7. Restart PC

I updated to the latest version of Brave 2 hours ago and immediately had issues accessing my Google account. I cannot access my account on Gmail, Google Calendar, Google Maps. I can still use Maps and search anonymously. I’m encountering the exact same issue the OP detailed.

I’ll give this a try tomorrow. I don’t think it could be the DNS because I can use Edge and gmail works and brave does not. Google phone also works in Edge, but not in Brave. Restarting the PC shouldn’t make a difference either. Brave appears to be the issue.

1 NO VPN
2 Cleared all cache
3 ?
4/5 removed finger print and disallowed third party gmail access
and reset network settings
Before rebooting, I tried to access gmail and the same error appeared even though all gmail passwords were deleted.
I then rebooted and every thing worked. Something in brave was hosed up and the rebooting apparently fixed the problem.

1 Like

I’ve repeated all the steps and still have the same issue.

  1. No VPN
  2. Cleared, browser cacher, cookies, and password related to google.
  3. Deactivated browser extensions
  4. Allowed social logins
  5. Disabled fingerprint blocking
  6. Used Terminal to flush DNS sudo dscacheutil -flushcache;sudo killall -HUP mDNSResponder
  7. Restarted Mac

Repeated steps twice, and still unable to sign in.

“400. That’s an error., The server cannot process the request because it is malformed. It should not be retried. That’s all we know…”

I am running the latest version of Brave on Mac OS 12.2.1, 1.37.109 Chromium: 100.0.4896.60 (Official Build) (x86_64)

The version of Brave on my iPhone can access my Google account perfectly fine.

Try updating windows. I got so sick and tire of the windows updates consuming the PC, I turned them off and I think that had something to do with brave issue.

Thanks @RjAqauponics!! I updated to Mac OS 12.3.1, and now my Google accounts are working. The Brave update on my older version of Mac triggered something that didn’t agree with Google’s services. Once I updated to the newest version of Mac OS, I was able to sign in to Google’s services. I’m logged in to my account on Gmail, Calendar, and Maps. It had nothing to do with my Brave browser extensions, fingerprinting, cookie or ad-blocking settings.

Ditto! That solved my issue. Thanks be to God!

Try updating windows. That worked for me!