YouTube video playback issues

While using Brave on YouTube, the videos pause and buffer all the time. If you turn off hardware acceleration it stops that but then the videos become choppy and stutter and hardware acceleration is needed for other sites. I can watch the same videos on other browsers with no issue.

@Kev_The_Galaxybender are you using NVIDIA? If so, have you changed settings for Background Application Max Frame Rate within NVIDIA?

awesome, that seemed to have worked. What framerate would you recommend? I have a 60fps gsync monitor. Should I set it to max frame rate or 30fps default?

@Kev_The_Galaxybender Well, actually that came up because of a different issue, which you can see at Brave weird performance on nvidia - #2 by Saoiray

In that, people who restricted it to like 30fps were seeing YouTube and other things get slow or choppy like you mentioned, unless they disabled hardware acceleration. So when I was seeing you mention something similar, I was curious if you did have it enabled and that’s why?

Keep in mind that hardware acceleration runs through your graphics card. So if it’s set to restrict frame rate and all, it will also slow down Brave. Meaning you should likely keep it to max frame rate or would need to have Brave as an exception.

What were your settings like and what are you saying seems to have worked? (What settings is it at when you say seems to have worked?)

well I don’t have hardware acceleration turned on

also I did not have this option turned on either.

Btw I’m still experiencing some stutter on occasion as well

i have just installed brave ios update on my ipad beforehand youtube was fine but now after the brave update it is impossible to watch any youtube channels live or prerecorded, the stream buffers and freezes around 2 to 3 minutes from starting, ipad 8th gen ios 16.5.1

Yeah I think the update broke something

I’ve had a few issues with video and media playback in Brave on my nvidia. As was suggested, exempting Brave from the “Global Settings” you have helped me solve my issues. I believe Vsync and MFAA were my main culprits. But with its own application profile in your nvidia settings you can disable all settings and toggle them on one-by-one until you see what’s causing the issue. Hope that helps!

I have brave set to it’s on profile. the issue is I need vsync as it’s how gsync works. So this may be a bust for me

also I noticed I get end title cards on youtube. anyway get rid of those? I want to switch over to Brave completely sooner than later.

Try changing the blocking to aggressive. I never get title cards on my main PC with these settings.

Not to offend but why a gsync monitor at only 60Hz? (You said fps I assume you meant hertz). You can try alternate vsync settings like adaptive, or I personally use Fast (vsync is only on when framerate is above monitor’s refresh rate, and off when below it). These are just shots in the dark I’m not super familiar with the internals of Brave or your system.

I have to limit the frame rate of the monitor to 59hz and have vsync on for gsync to work correctly. It’s the way it works and it works better than freesync on this monitor.

Also the monitor only goes up to 60hz

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.