Serious Youtube Playback Problems

After updating Brave to the latest version, Youtube videos now stutter, play slowly (slow motion), and get stuck. Audio is fine (other then when the video stutters). I’ve never had any problems like this before, and my computer and internet are both way too fast to be having performance issues. Not having problems with any other programs, just brave. In addition to video playback being terrible, the browser itself is sometimes loading pages slowly.

Simple browser/computer restarts haven’t helped. Disabling Shields hasn’t helped. Hardware acceleration is turned on. I have also uninstalled, deleted anything left over, and reinstalled. Looks like either the new Brave update or maybe a new Windows update broke something. I haven’t installed any other new programs recently.

I’ve tried playing Youtube videos on other browsers and did not have any problems. It is only happening with Brave.

Version 1.21.76 Chromium: 89.0.4389.86 (Official Build) (64-bit)

Would check Task manager (Brave, More Tools, Task manager) Check if there is any high usage cpu/ram. Try in private window mode also.

Also upgrading your gpu drivers may help, since youtube will use the GPU acceleration.

Does the stuttering change when using different resolutions 480p, 720p, 1080p… also check GPU/CPU usage between each

Hey there !
I am having the same issue. I have been using Brave for 1-2 years now, never had a problem like this, until now.

If I stop the video, there is no usage, under video playback, there is heavy CPU usage.
Also, the same is happening in private mode, video resolution doesn’t matter either.
No, nothing is outdated, etc…

@mrsbutterworth @Nolhain ,
Can you check whether or not the issue persists after disabling Hardware Acceleration in the browser? You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Yes, this removes the problem, this feature should not be disabled though, right? :smiley:

@Nolhain,
That’s good to know. Yes, it should, but HWA has been known to cause issues in Brave – we have a wiki entry on it where we are capturing data to resolve the issue:

Hmm, I see, interestingly enough, even when enabled now, it doesn’t seem to use the GPU.
That is what it is supposed to do with acceleration, right ?

That is correct – however I’m not sure whether or not it defaults to using the GPU. I believe it offloads certain tasks (likely more expensive ones) to the GPU when certain conditions are met.

Alright, well, thank You for the quick reply and the dirty fix ! :slight_smile:

P.S.: super unrelated but since I seem to have your attention, here is a small question:

Do You guys and gals plan on having the ability for the browser to make a dark scrollbar the default one ?
I and potentially a lot of other dark-mode-freaks would be super pleased, if it did :smiley:

@Nolhain,
I’ve opened the following issue for the developers to review – appreciate the feedback:

1 Like