YouTube videos run slowly

Description of the issue:
YouTube videos run poorly, especially 60fps. There is plenty of buffer and yet frames are dropped. At 1080 it’s manageable, but 1440 and 2160 stutter like crazy.
Full screen, default, theatre - doesn’t matter.
Hardware acceleration is enabled (already tried disabling it - even worse), already reinstalled the browser, Brave is the only application running.
Other browsers on the same computer play 2160p60 flawlessly.

How can this issue be reproduced?

  1. Play any 1080p or higher video on YT
  2. Enable ‘stats for nerds’

Expected result:
Videos should play smoothly

Brave Version( check About Brave):
Version 1.46.133 Chromium: 108.0.5359.71 (Official Build) (64-bit)

Additional Information:
Windows 10
GTX 1050
Driver Version

1 Like

Hello there @arathefu please accept my apologies for this performance issue with Brave. Could you please try opening your main profile in private or guest mode to see if the pages load? If they do load, try disabling your extensions to see if this is the cause of the issue.

You can open a Guest Window by going to Main menu --> Open Guest window:

  1. On your computer, open Brave.
  2. At the top right, click Menu → More tools → Extensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.

I have no extensions in Menu -> Extensions.
I’ve disabled Extension: Brave and Private Extension: Brave in Menu -> More tools -> Task manager, tested separately main window and guest mode - still drops frames.

@arathefu Three completely different questions. Treat them independent of each other and don’t combine.

  • Have you tried with and without Shields?

  • If you go to brave://settings/shields/filters and enable Fanboy Annoyances List and uBlock Annoyances List, do you see any difference?

  • Try going to brave://flags and enable Vulkan. Curious if it might help.

  • Shields on, shields off - stutters the same
  • Fanboy Annoyances Lists - no difference
  • Vulkan - black screen
1 Like

@arathefu Issue only happening on YouTube? Video plays fine elsewhere?

So far I only encountered it on YT.
Tested, works fine.

1 Like

@arathefu try clearing your cookies and site data from Brave to see if the stuttering no longer happens.

  1. Click on the Menu icon in the top right, and go to Settings
  2. Go to Additional settingsPrivacy and SecurityClear browsing data
  • A quicker way to get to this page would be to enter brave://settings/clearBrowserData into your address bar
  • See Advanced for a breakdown of the data you can clear
  1. Deselect Browsing history and Cached files (if you only want to clear cookies)
  2. Click Clear data

Let me know if that works.

I think that helped a bit, but there’s still occasional stutter, especially when there’s a lot going on on the screen.

EDIT: It only helped for certain videos, others are still choppy (e.g.

1 Like

@arathefu does this happen if you are logged out of your Google account when playing videos on YouTube? Also try checking for any Brave, GPU drivers or Windows update you can install to see if it works.


It’s the same whether I’m logged in or not.
Windows, GPU and Brave are all up to date.

1 Like

@arathefu try going to brave://flags/ and searching for Vulkan and Choose ANGLE graphics backend if they are set to default, please enable them to see if this changes the performance issues, if not disable them.

Let me know if that works.

I don’t have the Vulkan option:

Enabling Vulkan stops videos from working: audio plays but image keeps loading and loading.


On that case, please keep Vulkan disabled and try installing the Beta or Nightly version of Brave to see if the issue persist on those versions

Be waiting for your response.

Vulkan is its own settings. If you were looking for it under Choose ANGLE graphics backend that would be why you didn’t see it there.

Both are dropping frames just like the regular version.
I did not import anything or change any setting, ran them straight out of the box.

1 Like

@arathefu are you connected to the internet on your device through an ethernet cable or a wireless connection? If its a Wi-Fi connection, try forgetting your current connection and then connect again or use a different network.

Let me know if that works.

I had the same problem with 1080p 60 Fps, but I fixed it, plus the fact that my PC is not the most powerful, it’s satisfying to watch in those qualities. Currently I switched to Windows 10, (I used to have Windows 8.1) and due to the high resource consumption of Windows 10, and that my PC is not powerful, I use an external program to watch videos in 1080p 60Fps. But I still watch in those qualities

Solution to my problem of loss of FPS’s:

1 Like

@Kevin_cc I use cable connection.

@Sxmpra-T I had high hopes for these settings but they made absolutely no difference on my setup :frowning:

I ran some more tests:

  • 30fps and 50fps videos play smoothly, even at 4K.
  • 60fps stutter, even at 1080p.
  • It’s exactly the same on Ubuntu 22 (if that helps any).

@arathefu could you please trying to connect to a different network to see if this makes any change regarding the buffering?