Youtube dropping frames

Description of the issue:
Youtube videos dropping frames, lagging, stuttering

How can this issue be reproduced?
Watch any video in high resolution or FPS

Expected result:
Not to drop frames.

Brave Version( check About Brave):
v1.60.125

Additional Information:
Videos play fine in Chrome and Firefox. Zero dropped frames.

If I disable hardware acceleration then the video plays fine, but I can’t view HDR videos. And I also need to keep hardware acceleration on for work applications.

Troubleshooting Steps:

  1. Fresh install of latest GPU drivers
  2. Cleared Cache in Brave
  3. Disabled Smooth scroll flag (seen in another post here).
  4. Disabled G-sync.
  5. Restarting PC and making sure that youtube was the only thing open.
  6. Disabling ad blockers.
  7. Tested in private window (no change).

PC specs:
CPU: Ryzen 5 5600X
GPU: RTX 3060ti
Monitor: Acer Predator 1440 res, 160hz refresh, HDR on, G-sync on.
Windows 10

Edit: I forgot to mention that I first noticed this issue like a week or two ago. I have been procrastinating the troubleshooting because I was hoping it was just a bad Brave update that was going to get fixed.

I believe I fixed it by enabling these settings in the NVIDIA Control Panel;

Manage 3D Settings > Program Settings > Brave
Background Application Max Frame Rate: Off
Low Latency Mode: Off
Max Frame Rate: Off
Monitor Technology: Fixed Refresh
Preferred refresh rate: Application-controlled
Vertical sync: Use the 3D application setting

Restart Brave after applying these settings.

So far, I am getting zero dropped frames when watching 1440 60fps HDR videos both windowed and fullscreen. The only thing I notice is that my display cuts to black for 1 second when I enter or exit fullscreen mode (I assume turning G-sync off?). I still don’t think G-sync is the culprit, but turning it off for fullscreen video is not a bad idea.

NvidiaBrave2
NvidiaBrave1

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.