Windows upper border missing

Description of the issue:
When Windows 10 windows borders are active (Settings > Personalization > Colors > Title bars and window borders cheked), Brave windows upper border is missing (while left, right and botton are present).


Here you can see (or don’t :D) the missing upper border (enlarge the picture).

How can this issue be reproduced?
I have no idea.

Expected result:
Borders should be drawn for all four sides of the window like every other application.

Brave Version:
Version 1.43.89 Chromium: 105.0.5195.102 (Official Build) (64-bit)

Additional Information:

  • Windows desktop isn’t scaled: 100% scale and resolution native to my monitor.
  • I uninstalled and reinstalled Brave multiple times both keeping and deleting the folder “C:\Users\username\AppData\Local\BraveSoftware\Brave-Browser\User Data”
  • Brave Beta (Version 1.43.79 Chromium: 104.0.5112.102 (Official Build) beta (64-bit) ), currently installed alongside Standard release, don’t present this issue.

Thanks in advance.

Not sure what’s going on, but there’s a good chance it’s an issue in upstream Chromium – and hopefully one that’s already been fixed in that codebase.

Quick way to check might be to try a Nightly copy of Brave, assuming the Chromium version is significantly later than what’s in 1.43.89.

First of all thanks for the answer.

Ok so:

This up here is the latest Nightly build and, as can be seen, presents the same window upper border missing bug.

Yesterday I installed the Beta build:

This version didn’t had the problem but today there was an update and…

Now the beta also is missing the upper border.

I hope this can be resolved because is very annoying.

Just a quick question: I’m the only one using windows borders?