Window appears as blan but, --disabe-gpu is not working

Description of the issue: When I open Brave, the window appears completely blank. I can close it by clicking on the top right corner, but I have to guess the position of the red cross to do so. Here is a screenshot:


Steps to Reproduce:

  1. Toggle hardware acceleration (turned off, I believe).
  2. Click the button to restart and apply change.
  3. The window appears blank.

The “–disable-gpu” method is not working.

Actual Result (gifs and screenshots are welcome!): I see a blank window.

Expected result: When you open Brave, it should display the browser interface.

Reproduces how often: Every time.

Operating System and Brave Version (See the ‘About Brave’ page in the main menu): I can’t access the About Brave page, sorry. I am using Windows 10.

Additional Information: I’m not fluent in English, so I apologize if my writing is difficult to understand.
Thank you for taking your time reading my topics :wink:

I still have this issue

Apologies for the late response time here.

Can you please try launching a Private window in Brave and tell me if it also appears blank? Additionally, you stated that Hardware Acceleration is disabled which might be causing the issue (although I am not convinced it is). You’ll want to change the flag to --enable-gpu to toggle it on. You can try that as well and see if that makes any difference.

Thanks for your reply. I tried launching a private window, but it just didn’t launch. The “–enable-gpu” didn’t work either. Also, I would like to mention that I am sure that I toggled this option, pressed the restart button, and then everything appeared as blank. Additionally, I found that when Brave (blank window) is running, there is a massive amount of tasks in the task manager (20). This may be normal, but I have never seen a program with this amount of subprocesses. Also, since the private navigation seems to crash (it doesn’t open in the task manager either), I could try to execute Brave in private mode with CMD, so I can see the errors. If none of these work, could you explain to me where the Brave options are located so I can manually reset them without losing all my favorites, extensions, etc.?

Thanks for your help.

Next step I think is to try launching with a new profile and test to see if it opens properly. In place of the --disable-gpu flag, please try using

--user-data-dir=C:\Users\[your user name]\Desktop\test

This will launch Brave with a new profile (test) created on your Desktop. Note that you can delete this after testing — we’re simply trying to test and see if you can get the browser to open with a fresh profile.

Hey, I didn’t tried this. But I solved my problem by clearing cache and cookies (I was cleaning my computer with avast cleaner). Thank you really much for your patience

1 Like

Thank you for the update.

Glad you were able to resolve this issue.