Latest Brave Browser Page is Invisibles

I have two Toshiba A305 Satellite laptops that I tried to install Brave. They are both running Windows 7 32 bit w/ SP1. One has an ATI Mobility Radeon HD 3650 graphics “card” and the other has an Intel Mobile Graphics Media 4500MHD “card” (they are built in). They both were previously running FF prior to the attempt to install Brave. When installed, the browser window is invisible (see attached picture). It is there and it will grab the focus. You can also see that Brave is running in the Process Explorer window. What is showing appears to be a dialog box - clicking around randomly finally gets it to close, making the browser entirely invisible.

This problem really has me perplexed, since this is the first time I have ever seen a program fail to properly hook into the display. I’ve looked for earlier versions of the browser to try, but I can’t find them, if they are even available.

I have another computer with Brave installed and it is running perfectly (it is running the 0.64.77 version).

@SLK001 welcome to the community sorry this took a while had to dig through past post to find the solution for you.

  1. Find the shortcut for Brave (generally on Desktop), right-click and select Properties from the context menu.
  2. Click into the “Target” field, and type --disable-gpu at the end of the path. Note that you must type this outside of the quotes with a space between the flag and quotes . It should look something like this:


Click Apply then OK then open the modified shortcut you just created.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.