Weird bug filling password

Description of the issue:

I am not able to log in to my router using Brave browser on arch linux.
I have tried the following:

Logging in in Firefox on local network (gateway IP address) works fine, either if I fill out the password manually or paste it from a ctrl+c.

Password has the correct length: 10 to 20 chars, 2 uppercase chars 6 lowercase chars, 1 ‘@’ and 4 numbers

In an earlier version of the password I had an ‘_’ included, but I expected it to cause the problem.

In Brave I tried to manually input the password, and copy-pasting it. I even tried adding it to an password manager first and inputting it that way. Neither works, giving an incorrect login.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Login to the local gateway/router
Username cannot be changed (admin)
Enter the password (login button or hit ‘enter’

Actual Result (gifs and screenshots are welcome!):

Expected result:

correct login and go to admin dashboard

Reproduces how often:

10 times / every login attempt

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:

I have verified the correctness of the password used and I have tried multiple passwords for the portal.

Update: Same problem on MacOS Sonoma 14.3.1
Brave version:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.