Save password not prompted (second attempt)

Hi guys,
So this is going to be my second attempt to get help looking into this issue/bug.
I already posted here Save password not prompted
but the support stopped answering sadly. This issue is getting very irritating since for security my NAS loggs me out often and i need to keep copy/pasting my login/password. Sadly Brave dont offer to save this. Please read more below and in my previous thread.

Description of the issue:
I recently changed from Firefox to Brave and its working great. I have not experienced that on my
router and local NAS the username and password are not prompting the save password window.
I dont know why that is. On FF it did save them but Brave dont seem to detect i’m typing login/password.
Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Go to my router address: https://192.168.1.1:6444
  2. Go to my NAS: https://192.168.1.100
  3. Type in my login + passw
  4. Expecting Brave to prompt me to save my login + password but nothing happens.

Actual Result (gifs and screenshots are welcome!):
Brave to prompt me to save my login + password but nothing happens
Expected result:
Brave prompt me to save my login + password.

Reproduces how often:
Many times

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10
Version 0.65.121 Chromium: 75.0.3770.100 (Official Build) (64-bit)

Additional Information:
I have read the similar topics and they are not the same as this problem. Maybe i missed something but i did search.


I hope someone really starts looking into this this time. Cheers.

Hi team,

Can someone please start looking into this issue? its easy to re-produce i think.
Thanks!

I think i know “when” the issue occurs. How to solve it is something for Brave. Considering they never visit the forum well i dont think it will happen that soon. Anyway i thought i share what i find out.
I just changed my router and noticed that my login/passw was once again saved (brave offer to save them).
Usually i change in my router (Asus RT-AX88U) that i want to use https instead of http. Once i did this change the login/passw were not filled in and Brave did not even offer to save again. Just like before.
So it seems using https for local network causes this issue. I also use https for my NAS so thats why Brave dont offer to save the password there either.

I really hope someone can explain why this happens and maybe a workaround if there is any.

This topic was automatically closed after 30 days. New replies are no longer allowed.

Hey @vampyren sorry we missed you the first time!

@Mattches do you know if there are ways of adding autofill data manually (or any other way of making sure the prompt comes up?)

@vampyren it could be Brave’s auto HTTPS interfering with this. Try opening the Shields menu and disabling “Connections Upgraded to HTTPS” when you’re on your NAS’s admin panel.

Thank you for re-opening this!
I have actually disabled Shield but did what you asked and still no go.
Also tried allowing these without success:
image

@vampyren,
You may have to change the setting in Brave Shields defaults rather than the Shields panel, but it’s unclear. Try that and let me know if it works.

Thanks but i’m not sure what you want me to do. If i go to shields the changes are what i already done through

But either way if i disable shield all together for my NAS site it should work which it doesn’t.
If you want me to test anything in particular please let me know.

Any news or update @Mattches @Asad ?
Can you guys also test this yourself as well? i mean its pretty easy to re-produce. Save allot of back and forth in the discussion and more importantly time.

@vampyren,
When you login, do you see the “key” icon in the address bar? If so click on it and see if you get the username/password dropdown box:
image

Hi,
No i dont see that icon sadly.
Actually you asked me the same question in my previous thread :slight_smile:
The best thing would be if you could reproduce this issue locally. You guys maybe have a wifi router or a NAS? Even at home perhaps?

@vampyren,
Sorry for the repeat.
The reason I asked this time is because I did test this on my end and I was also not prompted to save the login/password data. I did however see the key icon in the address bar, which allowed me to save it.

I’m going to return to @Asad’s suggestion earlier as well. I know you’ve already said that you disabled Shields entirely for the site, but I’d like to try this anyway:
In Brave, got to Menu --> Shields and toggle the HTTPS option to Off. This disables the protection globally (you can turn it back on after testing this) and I’m wondering if doing so may change the behavior. We’ve had issues before where changing a setting in the Shields panel vs in Default Shields had different effects.

Sure no problem. I tried it and still the same
image

Closed the tab, browser and reopened everything to be sure. And still no key icon :frowning:

@vampyren,
If you don’t mind, can you try creating a new browser profile (Profile menu --> Manage people --> Add person) and try logging in using this fresh profile to see if you get the same results?

Tried it just now
image

And no change, also tried with the https on and then off. No change it wont offer to save the password and no key icon shows either :frowning:
Sorry this is a tricky one. Thanks for the continued help.

@vampyren,
Do you see the prompt to save your login data for sites other than your router?

Yes sure i do. Its only local network that has this issue. My NAS and Router (When i have https enabled on the devices). If i for ex disable the https on my router the key is shown on the top and it lets me select from previous login/password i saved.

This is the option on my router (Asus RT-AX88U) that breaks the password feature
image

1 Like

Hmmm interesting. Let me see if I can find a similar setting on my own router and I’ll see if I can reproduce this issue. Thanks for your patience.

1 Like

Sure and thanks allot. It should behave the same way i guess.