Weird Blurry Fonts when Brave Shields Enabled

I noticed in the last update that on some sites when Brave Shields is activated you get these weird un-smoothed and blurry fonts and they don’t go back to normal until Shields is disabled. Have no idea what Brave introduced in the latest version like some font blocking or blocking font providers or something but it so annoying having to disable shields just to get out of the blurry fonts it’s producing.

I currently have
Version 1.39.111 Chromium: 102.0.5005.61 (Official Build) (64-bit)
on Windows 11

Can you provide any screenshots? Also are you noticing this on any particular websites or anything? Guess it’s just trying to find out if it’s randomly happened anywhere, if it’s only a certain content, or what’s going on?

Also, is hardware acceleration turned on? If so, try it off just in case.

1
2222

I inserted some small pics of texts from a website to give you an example. The first blurry one is when Shields are enabled. The second picture shows Shields disabled and is more better to look, readable and not blurry, the way it always should be when shields are enabled and how it always was before some recent update messed up everything. This has nothing to do with HWA since it’s only a problem when shields get activated. I have no idea if someone in the last update messed around with the shields to provide font conflicts. I never had this problem before in Brave ever after using it for so much time now but this started occurring in the last 2 updates.

But I see someone tagged my post on this one below. Looks like some font conflict bug happening in Brave when shields are enabled? All problems disappear when shields are disabled.

Issue only exists when Shields is Enabled! Disable Shields and you are all good.

@fanboynz can you check in on this issue? I’m not even sure where else to begin. Also noticing other people opened similar topics. Since there’s mention of Shields, I’m thinking you’re the best to ask?


Well, not sure if this one is similar or different completely, but at least related to font issues.

Is there a sample site I check against? So I can easily compare previous Brave versions, Chrome and current Brave? @flasher777 I’m on Win11.

Well here is an example suppose I go to the link below with shields ON! I attached the first picture showing the blurry and weird looking fonts. As soon as I turn OFF shields on the site the fonts go back to normal the way they should be. It’s something with Shields interfering with Fonts. Never had this problem until the last few updates. This also has been happening with some emails I get in Gmail.


I’m using Windows 11 and [
Version 1.39.111 Chromium: 102.0.5005.61 (Official Build) (64-bit)

@fanboynz

Using Brave Browser v1.39.111 > New Private Window, visited https://old.reddit.com

  • Shields UP and aggressive
  • Allow javascript: https://old.reddit.com:443
  • Allow javascript: https://www.reddit.com:443

No font issues:

Using Firefox v99 > private window

  • Privacy and Security > ‘Standard’ Enabled
  • Privacy and Security > ‘Always using Private Mode’ Enabled
  • NoScript allowing javascript for https://old.reddit.com

No font issues:

Hi,

is there any update to fix this font issue coming soon? Many sites now I have to view with Shields OFF because of those fonts. Hope a new version can be pulled ASAP with a fix.

I noticed many people are having this problem and even on github there is a discussion.

@flasher777 Instead of disabling shields, you may want to leave shields up and try just disabling fingerprint blocking. That workaround seems to work for users. Copied information from User Solutions: 1.39.x below. You can either disable globally or by individual site by changing url shield settings.

ISSUE: Shields breaking text/fonts on some websites
Workaround: Disable Block fingerprinting at brave://settings/shields
Source: Brave Shields Affecting Fonts

Brave GitHub Issue Report:
Shields breaking text/fonts on some websites