Fonts appearing weirdly (hard to read) and unable to change it


After I update my Brave browser, some of the websites that I visit are showing totally different fonts. This is becoming an issue for me because these fonts are extremely hard to read and putting a lot of pressure on my eyes.

I am not sure how to reproduce this idea

Expected result:
Expected result is for the website to display proper fonts again and readable.

Brave Version( check About Brave):

Version 1.29.81 Chromium: 93.0.4577.82 (Official Build) (64-bit)

Additional Information:
I have tried to change the fonts on Settings but still no change.

  1. Check if disabling Hardware Acceleration via brave://settings/system resolves the issue.
  2. If Hardware Acceleration is not the culprit, try disabling Brave Shields temporarily via the Brave Shields icon in the address bar.
  3. If Brave Shields is not the culprit either, try clearing your all-time cache via brave://settings/clearBrowserData.

Hi. I have tried all of these. It isn’t working.

That’s unfortunate. Please, check if the issue is present in a fresh user profile so we can determine whether there is something wrong with your current user profile. Perform your tests after you close all windows of your current user profile, there must be only active windows of the fresh (test) user profile at the time.

1 Like

I think this is a scaling issue. Can you try to go to Settings > Display > Operating Help > Text Scaling > 100%
And leave the other stuff unticked.

Hi. Thank you. I have tried these and it is still the same.

I can’t seem to find those options.

I’m sorry I can not look for the correct english settings because I can’t change the language in my browser. But you can look for the Settings under “Display” options. There is somewhere the text-scaling option for sure. You can to set it back to 100%.

@kiritharen,
Can you please re-confirm that you’ve tried this in a fresh profile and it did not work?
Additionally, it may be a ClearType issue – can you please try the following:

  1. On your Windows computer, click the Start menu/in the Windows search bar
  2. In the search box, type ClearType . When you see Adjust ClearType Text , click it or press enter.
  3. In the ClearType Text Tuner, check the box next to Turn on ClearType
  4. Click Next , then complete the steps.
  5. Click Finish .

Hi Mattches,

I confirm that I have tried this in a fresh profile and it did not work.
I have also tried the ClearType issue like you suggested and it is still the same.

@kiritharen,
Hmm very interesting. Not sure what the issue would be then. To be clear, you’re not seeing this on all sites, just some of them?

Would you be willing to download and install the beta build of the browser to test and see if text appears the same there? Note that installing/running the beta will not have any effect on your current Brave installation.

Yes, I am just seeing this on some of the sites, not all of them.

And I just tried downloading the beta build, the text appears the same there.

I assume your computer has been rebooted since this issue started?

Do you have other browsers to test the same site(s) in and see if the problem is specific to Brave?

What about clearing the cache for the affected sites? (Click the ‘Lock’ icon, Site settings, click ‘Clear data’)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.