Blurry Text/Fonts - Brave Windows

Description of the issue:
The text-fonts are seem blurry in the Brave compared to other browsers. I see this was mentioned before couple of times, I tried this tutorial but doesn’t seem to fix it.
How can this issue be reproduced?

  1. Just open the Brave Browser and another one like Firefox or Chrome and check the text/font between them. You will see Brave is kinda blurry.

Expected result:
To not be blurry like in any other browser.

Brave Version( check About Brave):
Release Notes v1.46.144 (Dec 14, 2022)

Additional Information:
I really want to move to Brave long ago, but this bug and the blurry text/font which make me dizzy, holding me from the transition.

1 Like

Hello there @Retrial, please accept my apologies for this issue. Please try installing the Beta or Nightly version of Brave to see if the issue persists on those versions.

Hello, I’ve tried but doesn’t seem to solve these issues.
The text seems kinda blurry/pixelated.

1 Like

@Retrial On this case try going to brave://flags > Search Vulkan > Disable Vulkan > Retest

Let me know if that helps. Regards.

Sorry, this doesn’t help neither :face_with_diagonal_mouth:
Doing a research I am not the only one facing this issue.
I hope it will be fixed in future if any dev could take a look, my eyes can’t stand this :nerd_face:
Thanks for your help.

1 Like

@Retrial please go to brave://settings/appearance > Font size to see which option you have selected, also you can check under Customize fonts to see if changing fonts makes any difference.


I have these fonts. I don’t see any change if I change the font.
For example go to my xda thread here and check my name or even the bold fonts in thread. The text in Firefox or Edge seems ok but in Brave seems somehow blurry. Put the windows near each other to compare the fonts of each browser. It’s not like you can’t read them in Brave but you are straining your eyes.

1 Like

@Retrial do you have any other device where you can install Brave to see if the text shows the same as on the PC you are currently using?

Hi, sorry for the delay.

Yes, I tested this in my old pc and in my brother’s pc. We both see the text blurry compared to Firefox or Edge. Also a friend of mine noticed this.

I still believe it’s not something specific on my side.
Devs should take a look on this, I am not the only one facing this. Try to search “blurry text/font on Brave” in Google and you will find others have same issue.

It’s something important, as much as I like Brave, this issue makes the whole experience worse.

1 Like

Thanks for the information, I’ve shared this with our team and I’m waiting for further information on the matter. Once our team has answers, I will get back to you as soon as possible. I’ll tag @Mattches on this post.

Thank you. I will wait.

1 Like

@Retrial can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Hello,

Thanks, just tried but it’s still the same.

You personally, can’t see the blurry text/fonts? Do you use light or dark theme?
I use Dark theme and as I said and before, in my xda thread for example it’s clearly noticeable. Open the same on Firefox and it’s clear crystal.

Btw I use NVIDIA GPU, latest drivers installed, everything is up to date so it’s unlikely to be software problem neither hardware since it happening in other PCs too as I mentioned before.

1 Like

@Retrial I’m currently using Dark theme for my browser and I’m not seeing any blurry text on my end. Does changing the language Brave displays change anything?

Please try changing to English for example to see if you get a different result.

I will check tommorow but I don’t feel will change anything. As I said other users face this.

I will try to also record a video from my phone to show you the difference in Brave and Firefox. I hope it will be visible from a phone camera.

Thanks.

@Kevin_cc So I’ve recorded a video from my phone. I hope it’s visible the difference.
Check it on my mega cloud. (on brave-firefox-comparison video, brave is on left and firefox right)
Ofc, outside the video, the difference is much more noticeable with the eye.

@Kevin_cc also you can check here screenshot between brave and firefox, I think it’s more visible.

This is a chromium inherent problem. They apply something like an antialiasing filter or something. And although the amount applied is different between Chrome, Edge, Brave etc, it’s definitely there. And it’s not just the text - it’s applied to images and videos as well - it’s mostly visible in downsized ones. You can test a YT 1080 video in it’s default smaller window and compare between FF and any chromium browser - it’s pretty obvious. My point is, this is not a Brave problem, and I doubt they can do anything about it.
There is something you can do to reduce the softness slightly but not entirely: go to brave://flags/#use-angle and change to D3D9 → relaunch. And it also comes with a penalty: there is an obvious color shift towards yellow. At least that’s what my eyes see.

Hello,

Thanks for the detailed explanation.
I’ve read somewhere before that it’s chromium issue but as you said it’s not so noticeable in Edge for example. However if you compare it to Firefox even Edge seems somehow blurry but not in the level of Brave.

I agree, it’s not only the text and fonts, I just mentioned these specific because I thought it’s more visible if you look at the text.

I tried brave://flags/#use-angle and change to D3D9 → relaunch but compare to Firefox it’s still blurry.

If its an anti aliasing filter as you said, I guess Brave team can work to fix it or remove it. I doubt they can’t do anything if they dig it up.

@Kevin_cc @Mattches Please can you forward these to the development team and report us back if it’s possible a proper fix? I don’t want to damage my eyes. I will also try to open a GitHub issue. Edit: Opened an Issue at Github here.

Thanks.

@Retrial Go back to the Vulkan settings and set it to “Enabled”. It was sitting on a “Default” setting for me. When I enabled it, I got clearer text results immediately.

I hope this helps.

This could be caused by aging graphics drivers or cards. **speculation