Web Pages Glitchy and Unstable, Showing UI Artifacts

Description of the issue: When viewing web pages and scrolling, or when watching Video (YouTube, Rumble, etc.) The web page flickers and glitches, and black boxes and artifacts randomly display on screen. I believe these are parts of the Android UI as I can see the “Back” button (triangle) in some pictures. They appear to be tiled as well.

How can this issue be reproduced?

  1. Fresh install Android 13; update
  2. Install Brave
  3. Synced Brave into Sync Chain and set settings
  4. Go to web page, scroll down.
  5. Watch video on Youtube, Rumble, Twitch.tv, etc; wait, -OR- Interact with page while video plays; -OR- Scrub through video forwards or backwards
  6. Display is corrupted

Expected result: I can scroll content and still read it. Videos play as expected. (The same web pages display/videos play perfectly normal using Firefox.)

Brave Version( check About Brave): ver 1.60.116, Chromium 119.0.6045.134

Mobile Device details
Asus Zenfone 8, clean installed Android 13 then OTA updates to Android 13; Build TKQ1.220807.001

Additional Information:
As I said, this issue does not happen while using the Firefox browser (I downloaded to test). Installed all Apps from Aurora store without Google Play signed in. I synced browser so maybe the flags from my desktop are enabled on mobile version(?). I did go to brave://flags and reset all (as well as chrome://flags but I think they’re the same thing?) I’m willing to test and troubleshoot. Brave is my main browser and my main activities include scrolling web pages and watching videos so if it doesn’t work, I may have to switch to Firefox. I did install Kiwi browser and had the same issue, so perhaps it is something underlying in Chromium? This happens in Desktop mode of web pages as well as mobile. This happens in private tabs as well. This happens with shields down as well.

Same situation is happening on my Zenfone 8. Suddenly started after downloading the 2nd latest update. The situation persists with the latest update as well. SUPPORT IS NEEDED HERE!!!

To anyone having this issue, solution posted here: https://xdaforums.com/t/is-anyone-else-having-display-issues-artifacts-flickering-post-326-ota-update.4641628/ worked for me. It’s my thread on XDA. Basically, the TLDR is to go to brave://flags (or chrome://flags seems to work also) search for Vulkan, and enable. It was on “Default(Enabled)” for me, but changing it to “Enabled” fix the issues for me.

My guess is that something changed within Chromium/Chrome base browser, and Brave adopted that bug. I haven’t researched it further. Hopefully I’m not creating too many other issues by changing this flag… but it’s simply unusable without it set.

1 Like

Check with Chrome (we use the same engine), if it occurs there, it should be taken up with Zenphone devs.

Probably a bug in HW acceleration on the platform

1 Like

Thank you, it worked!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.