Video artifacts and glitches on youtube & html

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue: YouTube starts to “spaz out” as well as some other visual glitches on normal pages.
How can this issue be reproduced?

  1. Launch YouTube
  2. Play a video
  3. Observe

Expected result: Video plays normally

Brave Version( check About Brave): v1.47.171

Additional Information: This also happens in normal HTML5 video elements as well as other websites.
Please see video here: https://streamable.com/zkta6q
This suddenly started happening today and did not happen yesterday.
This is not a problem with YouTube as it also happens on other websites, and the glitches also occur outside of the website.
Yes, I disabled all my extensions too and reinstalled brave.
I also tried the Windows media player, Discord and Opera and everything (including YouTube) plays just fine.

In case this is relevant: GPU - RTX 3080, latest nvidia game ready driver

I also tried a stress GPU benchmarker and it rendered everything just foine.

@Speedy8135,
Thank you for reaching out.
Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

1 Like

Yes! That fixed it. Do you know what the sudden cause could be? Offloading everything onto the CPU instead of the GPU is not an ideal solution.

1 Like

@Speedy8135,
We have some known conflicts with HWA that other Chromium browsers don’t seem to have. More information can be found here:

2 Likes

Thank you for the link! I found on there an issue similar to mine and what seemed to fix it was this post:

After digging around in brave://flags, I have discovered that setting “Choose ANGLE graphics backend” to OpenGL has resolved this issue for me.

Sure enough, setting the backend to OpenGL solved it. Still odd how it would just happen out of the blue, update perhaps?

2 Likes

After a bit of digging, and for added context, turns out I forgot that I enabled “MFAA” setting in Nvidia control panel because I was testing some things:
image
As soon as I disabled it, hardware acceleration works normally now with the default settings!

I probed into this a little more because my Visual Studio Code instance was having issues as well with HWA.

2 Likes