Video Playback Choppy Since Yesterday's Browser Update

Description of the issue:
Video playback, like YouTube, Twitch, Netflix, are choppy since yesterday’s (Mar 2, 2022) update of V1.36.109. Choppy as 3-4 frames per second.

How can this issue be reproduced?

  1. Right click on “Brave” app.
  2. Click on “Properties.”
  3. In “Target,” type: --disable-frame-rate-limit (make sure to leave a space before “–”)
  4. Click “Apply” and (re)launch the app.
  5. Go to YouTube.
  6. Click on any videos.

Expected result:
Video should play normally with 30-60 frames per second.

Brave Version:
Version 1.36.109 Chromium: 99.0.4844.51 (Official Build) (64-bit)

Additional Information:
OS: Windows 10 Pro x64, 10.0.19043

2 Likes

@Kaiwen_Du ,

Use an Internet search engine; search criteria:

windows video device driver fps

An example of results, note that “DDU was used to completely remove all traces of NVIDIA Drivers” (I have never heard of ‘DDU’):

https://www.reddit.com/r/GlobalOffensive/comments/4xqunx/how_i_fixed_my_fps_after_latest_nvidia_driver/

I have the same issue but on Linux with “Brave 1.36.109 Chromium: 99.0.4844.51 (Build officiel) (64 bits)” on Fedora 35

Without --disable-frame-rate-limit args it’s ok, but when is present video playback skip lots of frame on render. Page scrolling and sound is ok.

EDIT 03/06: it’s a chromium bug since v99. I replicate this with MS Edge and chromium both Windows and Linux

Try installing this extension, it fixed the issue for me:

same issue even in Brave 1.37.109 Chromium: 100.0.4896.60 on Manjaro 21.2.5

do you have a link to the chromium bug or know which version fixes it?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.