SOLVED: Slightly choppy/strobing video playback on all sources compared to Chrome

When I play video from any source - youtube, plex, iptv webpages, embedded videos, they all play without interruption (audio or video). However, the video is mildly stroby - like it’s running at 20FPS instead of 30FPS.

When I visit the same sites using the latest Chrome, the playback is smooth as silk.

I have used brave://flags to compare all hardware/accelerated settings between the two browsers, and they are all identical.

The problem occurs on the Brave browser, whether a single tab is open, or many. Shields up or down has no impact.

I have tried resetting the profile to default, using private tabs, and even using alternate profiles. They all strobe where Chrome does not.

I’ve uploaded a short screen capture of the two side-by-side playing the same movie intro from the same website. Brave is on the left.

How can this issue be reproduced?

  1. Open any webpage that has a video component to it
  2. Press play
  3. watch slow frame rate playback

Expected result:

Smooth playback would be nice.

Brave version: Version 1.51.118 Chromium: 113.0.5672.126 (Official Build) (64-bit)
Chrome version: Version 113.0.5672.127 (Official Build) (64-bit)

EDITED TO ADD: When I watch the clip on this community post using brave, they both strobe :slight_smile: But if I view it on Chrome, only the left strobes. ARG!

Also wanted to add that if I’m playing anything with video on Brave, my CPU sounds like a hairdryer…

Well, I’m an idiot. Seriously considered deleting this post, but in the hopes that it helps someone with the same brain fart as me…

Quite some time ago, I was experiencing green artifacts on video playback on a very specific local video page (UI3) for a network video recorder called Blue Iris. At the time, the workaround was to disable hardware acceleration.

I was certain that everything was back to the default settings since that’s what it reported under brave://flags hardware acceleration. However, going to settings, system, hardware acceleration was still turned off. Once I switched it on, CPU dropped back down, and video is smooth.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.