Vertical Tabs without title bar: show favicon, not (x), on active tab

I’m using vertical tabs without title bar. It makes no sense to me that the currently opened tab shows an (x) instead of the favicon of the website! It should show the (x) on mouse hover ONLY, not all the time. Tested both on windows and macOS.
image
Note the (x) above Gmail for the brave community website (instead of the brave favicon).

Extra: even better if there was a setting to completely hide the (x). I always close tabs using the middle button of the mouse, or ctrl+w/cmd+w if it’s the active tab; even on touchpad, three-finger click == middle button click, so no need for the (x). The setting could be: [show on active tab, show on active tab on mouseover, never show].

The current behavior is “show on active tab”, which is odd to me!