Verify Wallet with no success

I have an Uphold account with BAT in it and also have BAT in my Brave wallet. My ID is verified on Uphold and I have given permission to link Brave with Uphold. When I try to verify my Brave Wallet it connects with Uphold and instantly get the message, " Something went wrong". I worked with Uphold for an hour and they gave me a list of things to try, which i did with no success. So i was directed to here by uphold because they said its not on there end. Any solutions will help. I only use one device, internet is secure and working, I have allowed Cookies from uphold, and even deleted both apps and re-download.

I have same issue as this. Same process. I did my get computer to link afterwards. But not my phone. Any luck?

Hi, another community member just trying to help! Posted information from previous topics that helped some community members.

If you are using an Android device, make sure both Brave and the device OS are updated to the latest versions then try this (again?) using the steps outlined:
Cannot Connect Brave Rewards with Uphold Account

@Chiphauler13 You didn’t say whether the BAT in Uphold was purchased or transferred from a previous payout. If this is the first time you are trying to verify with Uphold, check this:

  1. Make sure your account is verified at Uphold. Go to your profile page and there should be a verified date at the bottom.
    Example: Screenshot of a Verified Profile at Uphold
    Can’t verify and authorize the wallet, can’t connect Brave to Uphold - #2 by Impoiler
  2. Make sure all your personal information in your Uphold account is accurate and complete. For example, Uphold will verify your account with an incomplete address, but Brave needs your full address, including street number, street, city, etc.

Anyone experiencing the same issue and reading this topic!

  1. Android devices only: Does your device pass the SafetyNet check. You will not be able to claim rewards if your device fails the SafetyNet check.!
  2. Clear history/cache, exit Brave, and reopen. This works for some users.